Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Looking for help verifying world gen issues  (Read 973 times)

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Looking for help verifying world gen issues
« on: April 13, 2024, 01:34:04 pm »

Looking for anyone who would like to assist me in doing some experiments on world generation stability

All you need to do is make a mod that enables more entities I have six playable entities in my mod so that would probably be a good number to start with.

Then try to generate a large world with a long end history date 500 or more and large population site cap large population after civ creation and then let me know how successful your world generations are and what your error logs contain when they don't generate.

Because more and more I have no actual conclusive evidence but I'm pretty sure with a little Shadow of doubt that there is some weird correlation between playable entity number and worlds failing to generate.

I'm not a big time programmer or anything but it definitely feels like there's some math going haywired somewhere.

And currently the most reoccurring errors I'm seeing in my logs constantly are entities failing to generate speech music and and art forms and stuff and and null populations of animals

 I'm not sure if these have anything to do with the crashes or world's failing to generate but it's my firm suspicion that they are symptoms of something that is causing the crashes

Verdiumm

  • Bay Watcher
  • Too lazy to choose an image.
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #1 on: May 01, 2024, 08:00:01 pm »

I have a similar mod, but  adds 5 playables.

I had a bunch of problems, but i suspect at least in my case, it was the fact some of them didn't have any valid growables for outdoor farming and started in a desert.

After i removed that entity tag, it stopped failing.

That isn't your issue is it? i can't say i've had many problems after that, that weren't me doing something really dumb haha.
Logged

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Re: Looking for help verifying world gen issues
« Reply #2 on: May 02, 2024, 12:45:18 am »

I have a similar mod, but  adds 5 playables.

I had a bunch of problems, but i suspect at least in my case, it was the fact some of them didn't have any valid growables for outdoor farming and started in a desert.

After i removed that entity tag, it stopped failing.

That isn't your issue is it? i can't say i've had many problems after that, that weren't me doing something really dumb haha.

Best I can guess is it had something to do with bad entity setup many of my entities used the same default site type apparently this is a taboo setup...?

Verdiumm

  • Bay Watcher
  • Too lazy to choose an image.
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #3 on: May 02, 2024, 11:04:36 pm »

oh! that would actually made sense.

One of the times i had lots of crashes i couldn't work out was two entities with the same Start biome.

I don't get any now, presumably because they now all have entirely separate starts?

hmm.
Logged

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Re: Looking for help verifying world gen issues
« Reply #4 on: May 03, 2024, 10:23:26 am »

oh! that would actually made sense.

One of the times i had lots of crashes i couldn't work out was two entities with the same Start biome.

I don't get any now, presumably because they now all have entirely separate starts?

hmm.

Yeah my wild theory on it is that with the default site types depending on the map there are only so many of the default site types and if everyone's using the same site type the game just can't figure out where to put everybody then bang unhandled exception and the game crashes

aSpatula66

  • Bay Watcher
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #5 on: May 03, 2024, 01:38:39 pm »

That doesn't seem right, I've played and made mods with lots of civs assigned to the same default site types.
Logged

Eric Blank

  • Bay Watcher
  • *Remain calm*
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #6 on: May 04, 2024, 01:10:09 am »

I would also say that cant be the culprit, at least not on its own. World gen should restart if it cant place enough civs to meet the required number, not crash.

I also have a mod (Spellcrafts) that adds a dozen or so civs in total, and doesnt seem to have this issue. Or at least, it will place all the civs. Sometimes world gen still crashes, and Ive never been able to figure out why but the actual number of civs-to-be-placed in the world, or number of entities, doesnt seem at all related.

I in fact had a frustrating crash recently after generating a vanilla world for 6500+ years; after pressing the "keep world and return to title screen" button.
Logged
I make Spellcrafts!
I have no idea where anything is. I have no idea what anything does. This is not merely a madhouse designed by a madman, but a madhouse designed by many madmen, each with an intense hatred for the previous madman's unique flavour of madness.

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Re: Looking for help verifying world gen issues
« Reply #7 on: May 04, 2024, 09:47:21 am »

I would also say that cant be the culprit, at least not on its own. World gen should restart if it cant place enough civs to meet the required number, not crash.

I also have a mod (Spellcrafts) that adds a dozen or so civs in total, and doesnt seem to have this issue. Or at least, it will place all the civs. Sometimes world gen still crashes, and Ive never been able to figure out why but the actual number of civs-to-be-placed in the world, or number of entities, doesnt seem at all related.

I in fact had a frustrating crash recently after generating a vanilla world for 6500+ years; after pressing the "keep world and return to title screen" button.

I'll check later but I'm curious in your mod with civs did every single one of your civilizations have the same exact default site type??? And all playable ?


Okay I'm going over your raws on on spellcraft, your entities you have a ton of entities but not all of them are playable in fort mode all of mine are playable in fort mode

Maybe the world generator doesn't care as much about non-playable civilizations as it does about the playable ones I don't know all I know is there is a direct relationship to having a ton of default site type set to the same default site type on entities and the world generator acting oddly or not working at all

brewer bob

  • Bay Watcher
  • euphoric due to inebriation
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #8 on: May 04, 2024, 09:58:38 am »

Are you using site types PLAYER_FORTRESS or MONUMENT? Those may cause world gen crashes.

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Re: Looking for help verifying world gen issues
« Reply #9 on: May 04, 2024, 10:12:21 am »

Are you using site types PLAYER_FORTRESS or MONUMENT? Those may cause world gen crashes.

No I don't know what either one of those tokens even are I'll have to look them up what I was doing was I had a lot of playable entities and they all had the same default site type set to City I had five playable entities all set to default site type City the game does not like that

As soon as I switched it up and gave a variety of default site types, everything started working(no world generation crashes)

aSpatula66

  • Bay Watcher
    • View Profile
Re: Looking for help verifying world gen issues
« Reply #10 on: May 04, 2024, 10:19:07 am »

Do you mean crashes or rejections? Because having many playable entities can cause rejections if it can't place them all. Also could you show the raws? That would help
« Last Edit: May 04, 2024, 10:23:51 am by aSpatula66 »
Logged

aradar

  • Bay Watcher
  • Legendary bullshitter
    • View Profile
    • my steam workshop
Re: Looking for help verifying world gen issues
« Reply #11 on: May 04, 2024, 10:22:10 am »

Do you mean crashes or rejections? Because having many playable entities can cause rejections if it can't place them all.

Rejections I've noticed those I'm okay with I'm talking about solid crashes sometimes within a couple years sometimes within a hundred years sometimes immediately upon clicking the generate button

And that's what leads me to believe your comment that playable entities with the same default site type it causes the game to just not work due to a rejection spiral???? 😐

All I do know is that setting up the entity is very important and if you screw something up there the whole game can get screwed up