Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 166 167 [168] 169

Author Topic: Text Will Be Text - dfhack plugin  (Read 408617 times)

mifki

  • Bay Watcher
  • works secretly...
    • View Profile
    • mifki
Re: Text Will Be Text - dfhack plugin
« Reply #2505 on: July 05, 2018, 04:16:58 pm »

I was sick and didn't even open laptop this week, I'll make a build after work today.

UPDATE: Version 6.50 is ready.

taleden

  • Escaped Lunatic
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2506 on: July 06, 2018, 09:35:03 am »

Huzzah! Thank you, hope you're feeling better!
Logged

waterphage13

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2507 on: July 11, 2018, 09:28:36 pm »

Item overrides are working correctly:

[OVERRIDE:251:I:WEAPONRACK:WEAPONRACK::tier2:71:::IS_STONE]
[OVERRIDE:251:B:WEAPONRACK:Weaponrack::tier2:71:::IS_STONE]
[OVERRIDE:251:I:WEAPONRACK:WEAPONRACK::tier2:72:::WOOD]
[OVERRIDE:251:B:WEAPONRACK:Weaponrack::tier2:72:::WOOD]
[OVERRIDE:251:I:WEAPONRACK:WEAPONRACK::tier2:73:::IS_METAL]
[OVERRIDE:251:B:WEAPONRACK:Weaponrack::tier2:73:::IS_METAL]
[OVERRIDE:251:I:WEAPONRACK:WEAPONRACK::tier2:74]
[OVERRIDE:251:B:WEAPONRACK:Weaponrack::tier2:74]
fixed
« Last Edit: July 11, 2018, 09:34:10 pm by waterphage13 »
Logged

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2508 on: July 14, 2018, 06:38:03 pm »

Hello. While trying to build next branch for 43.03 just to get support for menu overlays (trickier than I expected), I ran into a quite unexpected failure:

Using unchanged 5.7-twbt from the repo (cloned) and 43.03-r1 dfhack unchanged from repo (cloned and built), compiles for twbt's resume/automaterial/mousequery fail with
Spoiler (click to show/hide)

And although make inst for twbt.plug.so itself succeeds, dfhack apparently can't load it, even after including the other plugins from 5.7 release from github (the twbt.plug.so there works fine though so no need to worry about that).

I'm probably missing something obvious, but searching this thread for libdfhack-version yielded no clues. I do have print mode set to twbt and do have shadows, transparent1x1 and white1x1 pixel files in data/art and realcolors.lua in scripts, so its not these though.

If it is not too much trouble, can (general) you please point out what I'm doing wrong here?
« Last Edit: July 14, 2018, 06:41:13 pm by Fleeting Frames »
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2509 on: July 14, 2018, 08:32:20 pm »

How exactly did you obtain DFHack for 0.43.03? Hint: the right way is using Git, checkout the 0.43.03-r1 tag and remember "git submodule update". You also need to compile DFHack (you can skip all plugins, though).

But if you did that, I'm not sure what's going wrong. libdfhack-version is a small static library with version information, which was added to make DFHack incremental builds with version number changes much faster. However, it was added before 0.40.24-r3, so building TWBT against any DFHack version newer than 0.40.24-r2 should work fine, at least when it comes to -ldfhack-version. TWBT's makefile was updated around the same time to add -ldfhack-version.

Out of curiosity, is there a reason you're using TWBT 5 instead of 6? Somewhere along the 6.x branch (I think, or maybe later in 5.x), the three separate plugins were removed (mousequery was removed later) due to DFHack core changes making them unnecessary. Those core changes might not be in 0.43.03-r1, though, so then maybe TWBT 5 is necessary after all.

Can you paste the contents of stderr.log? If you can locate sections related to the 3 plugins and paste those, that would be even better.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2510 on: July 14, 2018, 08:58:18 pm »

Used 'git clone --single-branch --recursive -b v0.43.03 https://github.com/DFHack/dfhack' and skipped no plugins instead. Also, interestingly the resultant twbt.plug.so is ~8% smaller than the one in release.


Unfortunately I can't paste the sections related to my own compiled 3 plugins in stderr when they don't compile.

Yeah, I noticed they were removed later. I'm using unchanged 5.7 in above post since that is the latest version for 43.03 (which my fort is on - would prefer not to upgrade) + I know the github one works. (Though if I get things to work I'll likely branch out from it or twbt-next - got the later to compile on 43.03 too, but failed to load that too.)
« Last Edit: July 14, 2018, 09:07:54 pm by Fleeting Frames »
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2511 on: July 14, 2018, 11:43:23 pm »

Oh, there's a branch for 0.43.03. What overlays require that, anyway?
Also, what GCC version are you using?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2512 on: Today at 06:18:32 am »

Non-fullscreen lua viewscreens that display on viewscreen_dwarfmodest, basically. gui/liquids, dfstatus are two default examples, as well as my own constructmultiz (really needs the reminder for me) or relations-indicator (I've atm unbinded view unit hotkeys, but I want to rather take advantage of unpaused gui that warmist showed to give counts like idler display or fix mousequery issue). Was fixed by 43.05, or more specifically here.

*peeks into CMakeOutput.log* gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.10)

Ah, but I have installed 4.5, 4.5-multilib, 4.9, 5.4-multilib, lib32gcc-5-dev, libx32gcc-5-dev, lib32gcc-1 and 6.0.1(not a typo) packages. Can't find CMakeOutput.log, but I know twbt asks for 4.5+/4.8+ for next. Might that cause issues with 4.5 or 4.9 package used instead of 5.4?

E: Editing 5.7's makefile to use 4.8+ or 5.4+ fails to compile. Aw.
« Last Edit: Today at 06:23:50 am by Fleeting Frames »
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2513 on: Today at 08:24:24 am »

Does the TWBT version you're building support 0.43.05? If so, it does not support 32-bit DF, because TWBT dropped 32-bit support when introducing 64-bit (0.43.05) support. That could explain why -ldfhack failed too. You'll have to use a TWBT version that only supports 0.43.03 if you want to use DF 0.43.03. Out of curiosity, why do you want 0.43.03 anyway?

How exactly did it fail to compile? I don't think TWBT has ever lacked support for GCC 4.8, because of Linux using it. I'm not sure why 5.4 would fail to compile - it might fail to link, if you don't have the "-D_GLIBCXX_USE_CXX11_ABI=0" definition. Also, GCC 6.0.1 literally does not exist, as I've mentioned before - maybe someone made up their own version number, in which case I don't know for sure what that is.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Meph

  • Bay Watcher
    • View Profile
    • worldbicyclist
Re: Text Will Be Text - dfhack plugin
« Reply #2514 on: Today at 09:13:33 am »

Just wanted to mention that people are still reporting (random) crashes when using twbt redraw_all 1, which go away when they set it to 0. My best guess is a lack of RAM.

Did you ever add the option to print the entire texture catalogue TWBT creates in one file?
Logged
::: ☼Meph Tileset☼☼Map Tileset☼- 32x graphic sets with TWBT :::
::: ☼MASTERWORK DF☼ - A comprehensive mod pack now on Patreon - 250.000+ downloads and counting :::
::: WorldBicyclist.com - Follow my bike tours around the world - 148 countries visited :::

lethosor

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2515 on: Today at 09:35:59 am »

I don't see how redraw_all would be affected by RAM availability, and if they're using 64-bit DF, there's no way that a lack of RAM would crash DF. All that redraw_all does is redraw tiles to the screen more frequently - the tiles take up the same amount of space in memory.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Meph

  • Bay Watcher
    • View Profile
    • worldbicyclist
Re: Text Will Be Text - dfhack plugin
« Reply #2516 on: Today at 10:27:17 am »

Ok. I based that assumption on a report I got that went along the line of "I have a PC with more RAM now, and had no more crashes since".
Logged
::: ☼Meph Tileset☼☼Map Tileset☼- 32x graphic sets with TWBT :::
::: ☼MASTERWORK DF☼ - A comprehensive mod pack now on Patreon - 250.000+ downloads and counting :::
::: WorldBicyclist.com - Follow my bike tours around the world - 148 countries visited :::

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2517 on: Today at 11:19:33 am »

The twbt version I'm trying build with the errors above currently is 5.7, which is last one for 43.03 version, and thus doesn't support 43.05. (Hence the untouched_dfhack folder name - idea being that if I can't get it to work out of box I likely can't get it to work with changes either)

(I did get the ldfhack errors until I changed -m64 to -m32 when compiling twbt next branch for altered 43.03, but that's a different story - the 5.7 3 plugins' makefile already uses -m32, for whats it is worth.)


The plugins makefile set to 4.8+ or 5.4+ fails with
Spoiler: ldfhack missing errors (click to show/hide)

That seems to be exact same failure message attempting to compile plugins with makefile requiring 4.5+, however.


None of the files in 5.7's plugin folder have text D_GLIBCXX_USE_CXX11_ABI, however. Though adding at the end of CFLAGS line in their Makefile doesn't seem to do anything.

Mind, I'm not planning on doing anything with mousequery/automaterial/buildingplan, so they're a bit of side issue compared to the main plugin's compiled file failing to be loaded.

PS: Yeah, I've seen your message of it not existing before. And 43.03 because my Solstice Chronicle was done in 43.03. Would prefer to not upgrade partly due already having run an 43.05 fort, partly due the .04 combat changes before which I didn't get too much combat experience, partly due this seeming like an issue that should be easy to solve and partly due upgrading having caused bugs for other forts like the craziness of Ardentdikes in the past (all through .40).

(I might eventually do it to boost FPS thanks to Sethatos' reports, but the world won't be having any historical artifacts in that case.)
« Last Edit: Today at 11:26:07 am by Fleeting Frames »
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2518 on: Today at 04:26:32 pm »

Yeah, that error looks almost exactly like your earlier error, but a bit more informative (it's a linker error, by the way). I asked about the -D_GLIBCXX_USE_CXX11_ABI=0 flag specifically because of this error in your stderr.log:
Code: [Select]
/home/username/DF/dfhack_compile/4303/DF4303/df_linux/hack/plugins/twbt.plug.so: undefined symbol: _ZN6DFHack12findEnumItemERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEiPKPKc
The "__cxx11" part indicates that the plugin is trying to use the C++11 ABI. Can you confirm whether TWBT itself is being compiled with "-D_GLIBCXX_USE_CXX11_ABI=0" (look at the make output)? CFLAGS probably won't work, because TWBT is written in C++ - try CXXFLAGS, maybe?

Also, why do you need 0.43.03?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Text Will Be Text - dfhack plugin
« Reply #2519 on: Today at 05:50:50 pm »

Well, that is not listed in the output of make inst.


Adding CXXFLAGS += "-D_GLIBCXX_USE_CXX11_ABI=0" after CFLAGS into makefile for twbt.plug.so results in another twbt.plug.so that doesn't work and is 8% too small.

Adding it to plugins' makefile does result in it appearing in output...of failure (note that it didn't appear in the output for main twbt5.7 make inst):


Also question: I'm not sure what other angle I can answer from it if my last edit to previous post didn't answer it. Being sieged by undead is major part of the fort, and .04 combat changes change their nature?
« Last Edit: Today at 05:52:49 pm by Fleeting Frames »
Logged
Pages: 1 ... 166 167 [168] 169