Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 7 8 [9] 10

Author Topic: Unofficial Linux Lazy Newb Pack  (Read 60025 times)

hawkeye

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #120 on: March 28, 2017, 02:53:30 pm »

Hello, brand new df player here.

I'm having quite a lot of issues launching the utilities with this pack. I feel like I'm missing something.

1) No "stonesense", "stone sense", nor "ssense" command in dfhack console. (nor anything like it listed in "ls" command)
I did "toggle" it enabled in the menu.

2) Armok shows blank screen and freezes up the main df window. Launching manually from terminal without df up it loads up, shows controls, but says no socket open on localhost:5000. Trying to then close Armok crashes everything...

3) Legends Browser does nothing... literally no output or window or anything.

4) Dwarf Therapist complains about path issues with "DwarfTherapist/share/..." not being there. I examined the paths in the script and they look fine to me and point to a real place so I'm a bit confused on that one... Editing the script to bypass all these path checks gets me an output in stderr log. Apparently I don't have libqt5 ?

Info:
Debian Jesse, Awesome wm, x64.
All behavior was identical between running as user / root and chmod 777 the whole directory.
Just running df works fine; it's just utilities and stonesense that don't work.

I suspect that all my problems are coming from one issue... maybe I need to install a shared lib that's missing?
Is there a shared variable or specific path that I need to setup?
Any help is welcomed.
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #121 on: March 28, 2017, 02:55:29 pm »

What DFHack version are you using? It will be displayed in the console on startup, and on the title screen (upper left corner). Versions for 0.43.05 up to 0.43.05-beta1 didn't include Stonesense. As for Armok Vision, there was a potential crash that could bring down DF that was fixed since DFHack 0.43.05-beta1. For Legends Browser, do you have Java installed? Have you tried installing libqt5 for DT?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

hawkeye

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #122 on: March 28, 2017, 03:07:33 pm »

My version:  http://dffd.bay12games.com/file.php?id=12762

That explains the bit about stonesense... Do you know why it was removed? Are there plans to restore it into next release?

I do have java installed.
What package does libqt5 come in? In searching I did not find much anything conclusive. Does it come in SVG?

Thank you for your help!
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #123 on: March 28, 2017, 03:24:56 pm »

Okay, it looks like the DFHack version in that is 0.43.05-beta1 (that was really all I needed).

Stonesense was removed temporarily because it required extra work to run with 64-bit DF, and that work had not been done yet. It should be back in DFHack 0.43.05-beta2.

Do you have Java 8? I believe that Legends Browser requires you to open a page in the browser. The exact page should be documented somewhere. Are you running it from a terminal, PyLNP, or something else?

A search for "qt5 debian jessie" turned up https://packages.debian.org/jessie/qt5-default. That may be useful. Otherwise, search for "qt5" in your package manager and see what you get. SVG is probably unrelated.

Edit: for Legends Browser:
On linux run "java -jar legendsbrowser-x.x.x.jar"
You default browser should open (if not open http://localhost:58881)
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

hawkeye

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #124 on: March 28, 2017, 05:31:19 pm »

Awesome! Thank you.

I'll give all these solutions a go when I get home tonight.
Logged

hawkeye

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #125 on: March 29, 2017, 12:35:00 am »

After installing qt5-default, I still have issues.

- Running dwarf therapist form terminal
./DwarfTherapist: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory

- Running dwarf therapist from tool
Verify $_DT_BINARY defined in /home/<user>/Downloads/df/LinuxLNP-0x43.05-rc1/LNP/utilities/dwarf_therapist/dwarftherapist script is set correctly.
I can bypass this check in the script, but basically every single check it does fails... and then it complains about the missing lib like when I run form terminal.

- I'm on debian jessie so my java spec is:
java version "1.7.0_121"
OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-2~deb8u1)
OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)

I think this is "java 7" so a missing version appears to be exactly the issue...
- running legendsbrowser in terminal
Exception in thread "main" java.lang.UnsupportedClassVersionError: legends/Application : Unsupported major.minor version 52.0

Rather than mess around with changing my apt sources to ubuntu servers just to install jre8, I pulled down a snapshot copy and tried to run it manually with jre8.
However, it seems that either it needs configured or it's just not compatible with debian jessie (which is prolly why it's not in official release anyway)
Anywho, trying to run manually gives me this:

jre1.8.0_121/bin/java -jar LinuxLNP-0.43.05-rc1/LNP/utilities/legends_browser/legendsbrowser-1.0.12.jar
properties not found: legendsbrowser.properties
usage: legends
 -p,--port <arg>     use specific port
 -s,--serverMode     run in server mode (disables file chooser)
 -u,--subUri <arg>   run on /<subUri>
 -w,--world <arg>    path to legends.xml or archive
[2017-03-28 22:31:02] INFO: server started on localhost:58881
Exception in thread "main" java.lang.UnsupportedOperationException: The BROWSE action is not supported on the current platform!
   at java.awt.Desktop.checkActionSupport(Desktop.java:225)
   at java.awt.Desktop.browse(Desktop.java:381)
   at legends.Application.initWebServer(Application.java:61)
   at legends.Application.main(Application.java:39)

I give up....
Logged

wierd

  • Bay Watcher
  • I like to eat small children.
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #126 on: March 30, 2017, 12:10:53 am »

Is this pack ever going to be updated to 64bit?

I just tried the latest tar.gz, and it could not find the (definitely installed, I checked) SDL1.2 libs. I am using a 64bit linux, and I presume that since this pack could not find the clearly installed libs, that it is looking for 32bit flavor ones.  I vaguely recall that it was discussed that  32bit pack remains 32bit, due to missing therapist and pals on 64bit.

Is that all we are waiting for? I dont like multiarching the crap out of my system just to satisfy reqs like this.
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #127 on: March 30, 2017, 12:39:37 am »

32-bit DF will always require 32-bit libraries. You'll either need to use 32-bit SDL/etc. or 64-bit DF.

This pack was last updated in September, when there weren't many utilities for 64-bit DF. Now, the issue could also be that it's not being maintained, although DT for 64-bit DF is still pretty experimental.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

wierd

  • Bay Watcher
  • I like to eat small children.
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #128 on: March 30, 2017, 03:48:17 am »

I think my wtf, is that this is supposed to be 64bit DF that I grabbed the pack for... but it still needed 32bit libs.
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #129 on: March 30, 2017, 08:35:51 am »

This pack isn't 64-bit. Which pack did you get?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Zoopy

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #130 on: August 10, 2017, 02:22:24 pm »

I don't know if this is relevant, but stderr.txt in the directory with startlnp contains the following lines:

Code: [Select]
ERROR: Unable to read current colors
  File "<string>", line 12, in <module>
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.lnp", line 67, in __init__
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.lnp", line 134, in initialize_ui
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.tkgui", line 174, in __init__
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.tkgui", line 274, in create_tab
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.tab", line 30, in __init__
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.graphics", line 39, in read_data
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.graphics", line 296, in read_colors
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.colors", line 121, in get_installed_file
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.colors", line 46, in get_colors
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.log", line 99, in e
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.log", line 85, in log
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/threading", line 810, in __bootstrap_inner
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/threading", line 763, in run
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.update", line 39, in perform_update_check
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.update", line 140, in update_needed
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.download", line 41, in download_str
TypeError: coercing to Unicode: need string or buffer, gaierror found

I have no user "michael" on my system. I erased stderr.txt and reran the program and the new stderr.txt had the same contents, so it isn't just left over from when the LNP was packaged.

-Harry

Bumping a very old thread, but I'm having this issue. I DO have DFHack enabled, so that fix doesn't work for me.

Anyone else possibly have any ideas?
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #131 on: August 10, 2017, 02:27:06 pm »

What exactly is "that fix"? There's not a fix in the post you quoted, but there are two in the post after it. If you tell us what you tried to do, that will make it easier to figure out what's wrong. Also, what distro are you using?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Jathe

  • Escaped Lunatic
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #132 on: August 14, 2017, 03:30:03 pm »

Would anyone be kind enough to give me links to all the dependencies I have to download for this to work? I'm using an old version of Crunchbang (Linux 2.6 something-or-other) and my computer has no internet access. I'm trying to hunt everything down and then figure out how to install them using my flash-drive but I'm not used to Linux and when I google the things I need I'm not exactly sure what I'm after. I would REALLY love to get this working! I posted in the other LNP Linux thread too, but no one replied.  :(

Spoiler (click to show/hide)
« Last Edit: August 14, 2017, 03:54:41 pm by Jathe »
Logged

Fleeting Frames

  • Bay Watcher
  • Spooky cart at distance
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #133 on: August 14, 2017, 08:07:07 pm »

GCC 5.1 at least, maybe?

libgraphics, perhaps.

Maybe libsdc?

Take both 32 and 64-bit libsdl, to be sure.

Caveat: it's been ages since I've had to install libraries. Wiki is perhaps more helpful, if you haven't read it: DF2014:Installation - Dwarf Fortress Wiki

lethosor

  • Bay Watcher
    • View Profile
Re: Unofficial Linux Lazy Newb Pack
« Reply #134 on: August 15, 2017, 08:30:23 am »

DF was built with GCC 4.8. You shouldn't need to install GCC.

Is "libsdc" supposed to be libstdc++? DF includes that, but sometimes you might have to remove DF's copy (causing it to fall back to the system one) for it to work. It'll be really hard to find a system without libstdc++ installed.

You only ever need one SDL - 32-bit or 64-bit, matching DF, since DF is the only thing that uses it. You'll also need SDL_image and SDL_ttf (same architecture). The wiki page is probably more helpful in determining the exact names for the libraries you need to install (different package managers call SDL_image different things, etc.).
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.
Pages: 1 ... 7 8 [9] 10