Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3]

Author Topic: LCS Compiling Issues  (Read 4150 times)

Sergius

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #30 on: July 22, 2016, 01:12:09 am »

Like I said, unchecking the option to look for updates in the install should get rid of the error.

I remember unchecking it, though. Clicked tdm-gcc again and this time the "Check for updates" box was still checked. Tried unchecking the box and clicking the option to manage a tdm-gcc installation before opening it again, the box was checked again. Can't seem to get that box to actually stay unchecked.


I think you're confused... when you install "tdm-gcc-5.1.0-3.exe" for the first time (probably uninstalling first if you already had) you uncheck the box then click on install, that means it won't check for a newer version during install and just use the provided file. If it's checked, it tries to connect, and that's what's giving you an error. It's not a setting that gets saved, it's asking you how do you want to install.

I just did a fresh install on another computer with that file and it worked fine.
Logged

Taberone

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #31 on: July 22, 2016, 01:41:30 pm »



It still gives the error when trying to use tdm-gcc 32. I removed the tdm-gcc installation and created a new tdm-gcc-32 installation with the "check for updated files" box unchecked but nothing changed.

Code: [Select]
"Liberal Crime Squad - Release": The compiler's setup (GNU GCC Compiler) is invalid, so Code::Blocks cannot find/run the compiler.
Probably the toolchain path within the compiler options is not setup correctly?! (Do you have a compiler installed?)
Goto "Settings->Compiler...->Global compiler settings->GNU GCC Compiler->Toolchain executables" and fix the compiler's setup.
Skipping...
Nothing to be done (all items are up-to-date).
Logged

Sergius

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #32 on: July 24, 2016, 06:58:56 pm »

Did you reset or auto-detect the toolchain executables/installation directory in the Global compiler settings?
Logged

Taberone

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #33 on: July 25, 2016, 01:48:02 pm »

Did you reset or auto-detect the toolchain executables/installation directory in the Global compiler settings?

Auto-detect makes it pick tdm-gcc-64, but resetting works. Now there's another new error message:

Code: [Select]
||=== Build: Release in Liberal Crime Squad (compiler: GNU GCC Compiler) ===|
||error: ld returned 1 exit status|
||=== Build failed: 1 error(s), 0 warning(s) (1 minute(s), 53 second(s)) ===|

No idea what that means.
Logged

Kamal-Sadek

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #34 on: July 30, 2016, 02:24:35 pm »

Did you reset or auto-detect the toolchain executables/installation directory in the Global compiler settings?

Auto-detect makes it pick tdm-gcc-64, but resetting works. Now there's another new error message:

Code: [Select]
||=== Build: Release in Liberal Crime Squad (compiler: GNU GCC Compiler) ===|
||error: ld returned 1 exit status|
||=== Build failed: 1 error(s), 0 warning(s) (1 minute(s), 53 second(s)) ===|

No idea what that means.

It seems to be a linker error, which happens when you try to use some kind of definition (whether it be for a function, variable, etc.), but the linker doesn't know where it's actually defined. (It could also happen because you mistyped the name of something, and it's looking for a misspelled name, and can't find it. But I'm going to assume you didn't mischievously edit anything).

It's probably because under Project Build Options -> Linker Settings, there's a library that is utilized but wasn't properly linked to (SDL, PDCurses, something or another), but more of the output / error is needed to decipher which library it is.
Logged

Taberone

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #35 on: August 11, 2016, 06:56:45 pm »

Did you reset or auto-detect the toolchain executables/installation directory in the Global compiler settings?

Auto-detect makes it pick tdm-gcc-64, but resetting works. Now there's another new error message:

Code: [Select]
||=== Build: Release in Liberal Crime Squad (compiler: GNU GCC Compiler) ===|
||error: ld returned 1 exit status|
||=== Build failed: 1 error(s), 0 warning(s) (1 minute(s), 53 second(s)) ===|

No idea what that means.

It seems to be a linker error, which happens when you try to use some kind of definition (whether it be for a function, variable, etc.), but the linker doesn't know where it's actually defined. (It could also happen because you mistyped the name of something, and it's looking for a misspelled name, and can't find it. But I'm going to assume you didn't mischievously edit anything).

It's probably because under Project Build Options -> Linker Settings, there's a library that is utilized but wasn't properly linked to (SDL, PDCurses, something or another), but more of the output / error is needed to decipher which library it is.

Don't remember touching or editing anything yet. Linker Settings look like this.



This also flashes for a split second before the "||=== Build: Release in Liberal Crime Squad (compiler: GNU GCC Compiler) ===|||error: ld returned 1 exit status|||=== Build failed: 1 error(s), 0 warning(s) (1 minute(s), 53 second(s)) ===|" message replaces it. Not sure how much it would page-stretch on anything less than a 2560x1440, so clicking the above image will lead to the full image.
Logged

zaimoni

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #36 on: August 11, 2016, 09:41:48 pm »

Unfortunately, ld is order-sensitive regarding library sequencing.  That weird duplication of SDL2 is actually needed due to a build problem with SDL(2), so I'd try putting PDCurses before SDL2.  (Generally speaking, if one library depends on another, the one being depended on should be after the one using it.  The MSVC linker link is immune to such lexical ordering concerns.)
Logged

Taberone

  • Bay Watcher
    • View Profile
Re: Code::Blocks "Easy Mode" compile doesn't give the latest LCS Version?
« Reply #37 on: August 20, 2016, 09:45:21 pm »

Unfortunately, ld is order-sensitive regarding library sequencing.  That weird duplication of SDL2 is actually needed due to a build problem with SDL(2), so I'd try putting PDCurses before SDL2.  (Generally speaking, if one library depends on another, the one being depended on should be after the one using it.  The MSVC linker link is immune to such lexical ordering concerns.)

Did this and nothing changed.
Logged

bot

  • Escaped Lunatic
    • View Profile
Re: LCS Compiling Issues
« Reply #38 on: August 25, 2016, 06:18:26 pm »

i tried everything here and i still get some hypot error i asked the auther for help and he refered this thread ugg at this point im hoping someone would be nice enough to just put one up precompiled as i obviously have no clue what to do
Logged

Kamal-Sadek

  • Bay Watcher
    • View Profile
Re: LCS Compiling Issues
« Reply #39 on: August 28, 2016, 11:40:23 pm »

Methinks the build system requires some major reworking. I'm not sure how old it is, but it sure is a major pain in the ass. I think that's what I'll be focusing on for a while, see if I can clean everything up and make it easier to compile on different systems. Let's see how that goes.
Logged

Kaje

  • Bay Watcher
    • View Profile
Re: LCS Compiling Issues
« Reply #40 on: November 13, 2016, 03:36:02 pm »

Is there ANYWHERE I can get a pre-compiled download of the latest GitHub version?
Logged

IsaacG

  • Bay Watcher
  • Mad Engineer
    • View Profile
Re: LCS Compiling Issues
« Reply #41 on: November 18, 2016, 10:22:06 am »

Is there ANYWHERE I can get a pre-compiled download of the latest GitHub version?
For Windows?
http://www.mediafire.com/file/8d6cji4r8djrqd3/Liberal+Crime+Squad+4.11.zip
If you just want to play it, this has no gameplay differences from the GitHub version.
Logged
Procedural String Support (Custom NewGame and Custom Pickup Lines!)

Quote
Many people, meeting Aziraphale for the first time, formed three impressions: that he was English, that he was intelligent, and that he was gayer than a tree full of monkeys on nitrous oxide.

Akumetsu: it's pretty much Liberal Crime Squad in comic book form.

Neckbeard

  • Bay Watcher
  • The Mouthiest of Breathers
    • View Profile
Re: LCS Compiling Issues
« Reply #42 on: December 11, 2016, 12:01:26 am »

Is there ANYWHERE I can get a pre-compiled download of the latest GitHub version?
For Windows?
http://www.mediafire.com/file/8d6cji4r8djrqd3/Liberal+Crime+Squad+4.11.zip
If you just want to play it, this has no gameplay differences from the GitHub version.

There's a bug that causes some values to be changed upon reloading a game.  If you start on nightmare mode, save the game, and reload it, the issues will shift and some supreme court justices will shift alignment.  Gun control shifts one point and become conservative, Civil Rights will shift 3 and become liberal, election reform will shift 2 and become moderate, Human rights will shift one point and become conservative, Tax structure becomes moderate, Drug laws are conservative, and Military Spending becomes conservative, Flag Burning and Women's Right's become Liberal, Immigration and Prison regulation become moderate.  2 Conservative Justices and one moderate justice will become liberal.

The values are over-written every time you reload the game it seems, at least the political issues affected are.  You can advance a month and let the issues change, to the point where they glitch out, because they moved off the chart, and upon reloading, the issues will be reset.
Logged

IsaacG

  • Bay Watcher
  • Mad Engineer
    • View Profile
Re: LCS Compiling Issues
« Reply #43 on: December 15, 2016, 12:44:14 pm »

Is there ANYWHERE I can get a pre-compiled download of the latest GitHub version?
For Windows?
http://www.mediafire.com/file/8d6cji4r8djrqd3/Liberal+Crime+Squad+4.11.zip
If you just want to play it, this has no gameplay differences from the GitHub version.

There's a bug that causes some values to be changed upon reloading a game.  If you start on nightmare mode, save the game, and reload it, the issues will shift and some supreme court justices will shift alignment.  Gun control shifts one point and become conservative, Civil Rights will shift 3 and become liberal, election reform will shift 2 and become moderate, Human rights will shift one point and become conservative, Tax structure becomes moderate, Drug laws are conservative, and Military Spending becomes conservative, Flag Burning and Women's Right's become Liberal, Immigration and Prison regulation become moderate.  2 Conservative Justices and one moderate justice will become liberal.

The values are over-written every time you reload the game it seems, at least the political issues affected are.  You can advance a month and let the issues change, to the point where they glitch out, because they moved off the chart, and upon reloading, the issues will be reset.

Huh.  I'm going to have to look into that.
Logged
Procedural String Support (Custom NewGame and Custom Pickup Lines!)

Quote
Many people, meeting Aziraphale for the first time, formed three impressions: that he was English, that he was intelligent, and that he was gayer than a tree full of monkeys on nitrous oxide.

Akumetsu: it's pretty much Liberal Crime Squad in comic book form.
Pages: 1 2 [3]