Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5 ... 28

Author Topic: Dwarf Fortress 0.43.04 Released  (Read 141380 times)

Random_Dragon

  • Bay Watcher
  • Psycho Bored Dragon
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #30 on: June 20, 2016, 05:10:49 pm »

Anyone seen soldiers with armor yet?

The only soldier in the keep I started in had the usual breastplate and helm. He also had a mail shirt, chain leggings, and gauntlets. At least one of the goblin bandits I killed had leather armor and helm, not sure about side gear they didn't use to reliably wear.

Whee, experiments in animal glue shall ensue.
Logged
On DF Wiki · On DFFD

"Hey idiots, someone hacked my account to call you all idiots! Wasn't me you idiots!" seems to stretch credulity a bit.

Max™

  • Bay Watcher
  • [CULL:SQUARE]
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #32 on: June 20, 2016, 05:14:09 pm »

Anyone seen soldiers with armor yet?

The only soldier in the keep I started in had the usual breastplate and helm. He also had a mail shirt, chain leggings, and gauntlets. At least one of the goblin bandits I killed had leather armor and helm, not sure about side gear they didn't use to reliably wear.

Whee, experiments in animal glue shall ensue.
Oh really, that's the first confirmation of additional armor being worn. Was he a weapon lord or something perhaps?
Logged

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: Dwarf Fortress 0.43.04 Released
« Reply #33 on: June 20, 2016, 05:24:15 pm »

I think bandits are still intentionally given patchy armor choices, if that matters.

Compiling one with XP compat now...  downsides to using the older SDK?
Logged
The Toad, a Natural Resource:  Preserve yours today!

Eric Blank

  • Bay Watcher
  • Never stabs friends, promise!
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #34 on: June 20, 2016, 05:42:16 pm »

I had the missing dll issue as well, running on windows 10, upgraded from a windows 8.1 install.
Downloaded and replaced with the new exe, and ignoring the security prompt I get now (the prompt specifically says the publisher could not be verified) the game boots up, lets me generate a world and begin an adventure. So that seems to have fixed the missing dll issue.
Logged
I make Spellcrafts!
I have no idea where anything is. I have no idea what anything does. This is not merely a madhouse designed by a madman, but a madhouse designed by many madmen, each with an intense hatred for the previous madman's unique flavour of madness.

Max™

  • Bay Watcher
  • [CULL:SQUARE]
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #35 on: June 20, 2016, 05:42:54 pm »

Makes sense with bandits, gonna generate an older world to increase the number of weapon lords and such, I assume that will have an influence, though that was actually a goblin soldier from a pit.
Logged

Random_Dragon

  • Bay Watcher
  • Psycho Bored Dragon
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #36 on: June 20, 2016, 05:45:19 pm »

Oh really, that's the first confirmation of additional armor being worn. Was he a weapon lord or something perhaps?

A regular hammerman. I would assume that established soldiers are more likely to generate with fuller armor?

Also. This is maybe the third time I've closed Dwarf Fortress, after a painful short adventure and some arena mode testing. And yep, it still only starts thinking something's wrong AFTER closing. I need to open and test the legacy version.

EDIT: Legacy version does NOT seem to suffer post-closure insanity. ¿Por que?
« Last Edit: June 20, 2016, 05:52:31 pm by Random_Dragon »
Logged
On DF Wiki · On DFFD

"Hey idiots, someone hacked my account to call you all idiots! Wasn't me you idiots!" seems to stretch credulity a bit.

Max™

  • Bay Watcher
  • [CULL:SQUARE]
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #37 on: June 20, 2016, 05:49:33 pm »

Hmmm, the world I was on was only 200 years old but I was checking the soldiers in taverns, keeps, mead halls, and so forth.

For the record, the linux version is stable, no crash or errors or whatnot, just the patchy armor.
Logged

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: Dwarf Fortress 0.43.04 Released
« Reply #38 on: June 20, 2016, 05:53:12 pm »

For XP people:

df xp test exe

Copy this into the SDL folder.  It has the exact same byte size as the last one, but I think it's different...  it threw up different warnings anyway.
Logged
The Toad, a Natural Resource:  Preserve yours today!

Random_Dragon

  • Bay Watcher
  • Psycho Bored Dragon
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #39 on: June 20, 2016, 05:58:23 pm »

Despite the unexpected errors, interesting changes thus far.

EDIT: I'm still wishing you'd take the five seconds to copy-paste giant desert scorpion back into the raws though. ._.
« Last Edit: June 20, 2016, 06:04:30 pm by Random_Dragon »
Logged
On DF Wiki · On DFFD

"Hey idiots, someone hacked my account to call you all idiots! Wasn't me you idiots!" seems to stretch credulity a bit.

Jazzeraint

  • Bay Watcher
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #40 on: June 20, 2016, 06:21:32 pm »

'mscvcp140.dll missing' causing a failure for the .exe to load for me. Win7, 43.03 has been working fine.

Spoiler (click to show/hide)

http://bay12games.com/dwarves/redist/msvcp140.dll

If you put this in the folder does it work, or does it give you another DLL that's missing?  I tried it on three computers, but they all came with the proper DLLs I guess.

Not that person but had the same issue, tried reinstalling Visual C++ Redistributable but it didn't work.

After downloading and putting that DLL in the folder it asks for a VCRUNTIME140.dll.

I'm getting this issue now, using the provided msvcp140.dll . Tried the new .exe offered in the SDL folder, but neither it nor the original .exe are working.
Would try the offered XP download, but I'm on win7.
Logged
The silver is responsible for this How?

DeKaFu

  • Bay Watcher
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #41 on: June 20, 2016, 06:25:29 pm »

The new test XP exe works!

...Sort of. It gives the security prompt, then launches and runs normally. But now after closing the program it pops up a "df_xp_test.exe has encountered a problem and needs to close." generic windows error message. Very similar to Random_Dragon's problem.

The game actually runs, now, though, so that's a huge improvement at least. Thanks for working on it. :)
Logged

Random_Dragon

  • Bay Watcher
  • Psycho Bored Dragon
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #42 on: June 20, 2016, 06:32:21 pm »

...Sort of. It gives the security prompt, then launches and runs normally. But now after closing the program it pops up a "df_xp_test.exe has encountered a problem and needs to close." generic windows error message. Very similar to Random_Dragon's problem.

This is some sorcery right there, these bugs. Have you tested the legacy version? It seems to work with no issues for me, but the text formatting is hideous compared to SDL, for some reason. ;w;
Logged
On DF Wiki · On DFFD

"Hey idiots, someone hacked my account to call you all idiots! Wasn't me you idiots!" seems to stretch credulity a bit.

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: Dwarf Fortress 0.43.04 Released
« Reply #43 on: June 20, 2016, 06:32:51 pm »

I'm getting this issue now, using the provided msvcp140.dll . Tried the new .exe offered in the SDL folder, but neither it nor the original .exe are working.
Would try the offered XP download, but I'm on win7.

The XP exe should work for Win7+ as well as the first new exe did, but there are still DLL problems with the new exes in general?  The new exe complains about the vcruntime140.dll?
Logged
The Toad, a Natural Resource:  Preserve yours today!

Jazzeraint

  • Bay Watcher
    • View Profile
Re: Dwarf Fortress 0.43.04 Released
« Reply #44 on: June 20, 2016, 06:49:34 pm »

I'm getting this issue now, using the provided msvcp140.dll . Tried the new .exe offered in the SDL folder, but neither it nor the original .exe are working.
Would try the offered XP download, but I'm on win7.

The XP exe should work for Win7+ as well as the first new exe did, but there are still DLL problems with the new exes in general?  The new exe complains about the vcruntime140.dll?

The pre-XP-test exe had the vcruntime140.dll error. The XP-test.exe is working without that error.

To comment on the rest of the thread, not receiving any error upon closing DF.
Logged
The silver is responsible for this How?
Pages: 1 2 [3] 4 5 ... 28