Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5 ... 14

Author Topic: LinuxLNP STABLE - 0.44.12-r02 x64  (Read 66881 times)

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #30 on: June 23, 2017, 01:33:03 am »

Download HERE

There were a few issues with some embark profiles and init settings with the last revision that I didn't notice until after I released it.  Those issues are fixed in this revision.

To Run: Simply execute the included startlnp script.

LNP IMPORT TIPS
When first launching a new version of the LNP, you'll be asked if you want to import files from a previous installation. If you select yes, open the previous version's df_linux folder in the file chooser dialog, then click ok. Selecting the LNP folder or the root of the pack will cause the import to fail. The import process will grab your DF saves, SoundSense and/or SoundCense sounds, gamelog, and dfhack history from the previous version.

Minor changes over previous revision:
  • Fixed duplicate axes in some embark profiles
  • Began placing README and/or help files for various utilities in ./LNP/about folder
  • Fixed PyLNP auto-import path for sounds
  • Reset EMBARK_RECTANGLE from 4:4 to 3:3

Utilities included:
  • PyLNP 0.12b
  • DF 0.43.05
  • DFHack 0.43.05-r1
  • Dwarf Therapist 37.0.0 (DanFritz's fork built with Qt4.8.7)
  • TWBT 5.84
  • Soundsense r2016-1 (you'll need to download the sound files yourself from within the application)
  • SoundCenSe GTK 1.4.2  (A c# audio engine for Dwarf Fortress based on Zweistein's SoundSense)  (*Requires Mono*)
  • Armok Vision 0.16.2
  • Legends Browser 1.12.2 (*Requires Java 8*)

Graphics packs included:
  • Afro
  • AutoReiv
  • CLA
  • GemSet
  • IronHand
  • Jolly Bastion
  • Mayday
  • Obsidian
  • Phoebus
  • Rally Ho
  • Spacefox
  • Taffer
  • Tergel
  • Wanderlust

Download HERE
« Last Edit: June 27, 2017, 08:43:59 am by Enay »
Logged

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #31 on: June 23, 2017, 10:14:58 am »

This is more of a bugfix release.  I didn't realize when I compiled Dwarf Therapist for the previous revision that some distros (Ubuntu, at the very least) wouldn't be able to run it.  I rebuilt with QT4 and tweaked the wrapper script, and it seems to work well in Debian, Ubuntu, and Fedora.  The errors about not being able to locate $_DT_BINARY are gone.  I don't have any other distros installed for testing, so feedback from Arch users would be appreciated.

I also wrote a wrapper script for Legends Browser, as I found that Fedora (and most likely other distros) don't allow for the launching of .jar files directly.
Logged

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #32 on: June 27, 2017, 08:44:01 am »

Download HERE

There were a few issues with some embark profiles and init settings with the last revision that I didn't notice until after I released it.  Those issues are fixed in this revision.

To Run: Simply execute the included startlnp script.

LNP IMPORT TIPS
When first launching a new version of the LNP, you'll be asked if you want to import files from a previous installation. If you select yes, open the previous version's df_linux folder in the file chooser dialog, then click ok. Selecting the LNP folder or the root of the pack will cause the import to fail. The import process will grab your DF saves, SoundSense and/or SoundCense sounds, gamelog, and dfhack history from the previous version.

Minor changes over previous revision:
  • Fixed duplicate axes in some embark profiles
  • Began placing README and/or help files for various utilities in ./LNP/about folder
  • Fixed PyLNP auto-import path for sounds
  • Reset EMBARK_RECTANGLE from 4:4 to 3:3

Utilities included:
  • PyLNP 0.12b
  • DF 0.43.05
  • DFHack 0.43.05-r1
  • Dwarf Therapist 37.0.0 (DanFritz's fork built with Qt4.8.7)
  • TWBT 5.84
  • Soundsense r2016-1 (you'll need to download the sound files yourself from within the application)
  • SoundCenSe GTK 1.4.2  (A c# audio engine for Dwarf Fortress based on Zweistein's SoundSense)  (*Requires Mono*)
  • Armok Vision 0.16.2
  • Legends Browser 1.12.2 (*Requires Java 8*)

Graphics packs included:
  • Afro
  • AutoReiv
  • CLA
  • GemSet
  • IronHand
  • Jolly Bastion
  • Mayday
  • Obsidian
  • Phoebus
  • Rally Ho
  • Spacefox
  • Taffer
  • Tergel
  • Wanderlust

Download HERE
Logged

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #33 on: June 28, 2017, 08:01:25 am »

Found a problem with r03 - d_init.txt has a typo, EMBARK_RECTANBLE instead of EMBARK_RECTANGLE.  This causes DF to use the default size of 6x6.

It'll be fixed in the next revision, but if you don't want to wait, just browse to df_linux/data/init and edit d_init.txt.  If you often change graphics packs, edit the d_init.txt files in LNP/graphics/packName/data/init as well.
Logged

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #34 on: July 03, 2017, 11:44:18 am »

Download HERE

Found a bug related to symlinks of some of the DFHack libs not resolving correctly.  This bug causes Stonesense to not load, and most likely other issues not immediately apparent.  I also fixed a typo in the init files.  Finally, re-imported the embark profiles from scratch, as I found some discrepancies between them and the set that PeridexisErrant publishes.  I run both Windows and Linux, so my goal is to make transitioning between the LNPs as seamless as possible.

I have also fixed the wrapper scripts for Legends Browser and DF Announcement Filter and turned on auto update checks for PyLNP.

To Run: Simply execute the included startlnp script.

LNP IMPORT TIPS
When first launching a new version of the LNP, you'll be asked if you want to import files from a previous installation. If you select yes, open the previous version's df_linux folder in the file chooser dialog, then click ok. Selecting the LNP folder or the root of the pack will cause the import to fail. The import process will grab your DF saves, SoundSense and/or SoundCense sounds, gamelog, and dfhack history from the previous version.

Major changes over previous revision:
  • Fixed missing DFHack libs due to improper .tar creation

Minor changes over previous revision:
  • Refreshed embark profiles.  Not sure how it happened, but there were minor discrepancies between the embark profiles in PeridexisErrant's LNP and my own.  This is no longer the case.
  • Fixed EMBARK_RECTANGLE typo in d_init.txt
  • Fixed dwarftherapist wrapper script causing potential issues with finding the memory layouts
  • Fixed wrapper script for Legends Browser and DF Announcement Filter
  • Turned on PyLNP's update check by default

Utilities included:
  • PyLNP 0.12b
  • DF 0.43.05
  • DFHack 0.43.05-r1
  • Dwarf Therapist 37.0.0 (DanFritz's fork built with Qt4.8.7)
  • TWBT 5.84
  • Soundsense r2016-1 (you'll need to download the sound files yourself from within the application)
  • SoundCenSe GTK 1.4.2  (A c# audio engine for Dwarf Fortress based on Zweistein's SoundSense)  (*Requires Mono*)
  • Armok Vision 0.16.2
  • Legends Browser 1.12.2 (*Requires Java 8*)

Graphics packs included:
  • Afro
  • AutoReiv
  • CLA
  • GemSet
  • IronHand
  • Jolly Bastion
  • Mayday
  • Obsidian
  • Phoebus
  • Rally Ho
  • Spacefox
  • Taffer
  • Tergel
  • Wanderlust

Download HERE
« Last Edit: July 03, 2017, 03:25:08 pm by Enay »
Logged

Tymewalk

  • Bay Watcher
  • Official "Wizzard"
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #35 on: July 05, 2017, 12:52:25 pm »

Just loaded that latest version on Ubuntu 16.04 LTS, dependencies fully installed. It kept giving me this:
Code: [Select]
ERROR: Note: Failed to read JSON from PyLNP.user, ignoring data - details follow
Traceback (most recent call last):
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.json_config", line 41, in __init__
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/json", line 290, in load
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/json", line 351, in loads
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/json.decoder", line 366, in decode
  File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/json.decoder", line 382, in raw_decode
ValueError: Expecting property name: line 3 column 1 (char 21)
(Which is double-strange because the user I was running DF under wasn't named "michael". Not sure why, although I've never used the LNP before)

PyLNP.user contained this:
Code: [Select]
{
  "updateDays": 0,
}

Removing the comma and changing it to this:
Code: [Select]
{
  "updateDays": 0
}

makes it work perfectly fine.
Logged
"They're going to blow up Earth? But that's where I keep all my stuff!" - The Tick

Ecaz

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #36 on: July 05, 2017, 03:18:43 pm »

Sorry to be dumb, but what's LNP?
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #37 on: July 05, 2017, 04:50:39 pm »

Yeah, sounds like the JSON file is the issue there.
(Which is double-strange because the user I was running DF under wasn't named "michael". Not sure why, although I've never used the LNP before)
It doesn't mean anything. That's the path of the file on the machine where PyLNP was built. It has nothing to do with your machine.

Sorry to be dumb, but what's LNP?
A pack with DF and a bunch of utilities, which are listed in the first post.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Bulwersator

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #38 on: July 10, 2017, 12:59:04 pm »

I have reproducible crash fo DT from this pack on Lubuntu 16.04. If squad is created DT crashes on reading squad data. If squad is deleted crash disappears. Is it a good place to report it? Or should I look for DT thread (I wanted to start here as it packages DT that may or may not be modified ("compiled Dwarf Therapist for the previous revision").

If "I'm probably going to stop working on this in the very near future" is already true then sorry for bothering you.

EDIT: bugged save: http://dffd.bay12games.com/file.php?id=13000 (try to connect with DT - crash. delete squad, connecting with DT works).
« Last Edit: July 10, 2017, 01:10:45 pm by Bulwersator »
Logged
The worst bug - 34.11 poll
Tired of going decades without goblin sieges? Try The Fortress Defense Mod
the Bugfixes apostle of Bay12forum. Every posts he makes he preaches about the evil of Bugs.

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #39 on: July 18, 2017, 03:36:45 pm »

I have reproducible crash fo DT from this pack on Lubuntu 16.04. If squad is created DT crashes on reading squad data. If squad is deleted crash disappears. Is it a good place to report it? Or should I look for DT thread (I wanted to start here as it packages DT that may or may not be modified ("compiled Dwarf Therapist for the previous revision").

If "I'm probably going to stop working on this in the very near future" is already true then sorry for bothering you.

EDIT: bugged save: http://dffd.bay12games.com/file.php?id=13000 (try to connect with DT - crash. delete squad, connecting with DT works).

Thanks for reporting this.  I just tested this out for myself and can confirm that the version of DT I included in the LNP crashes when a military exists.  The extent of my testing was to make sure it could read the dwarves in a new embark, and that labors could be assigned/removed.

The "official" Dwarf Therapist won't work on 64-bit yet, and hasn't been updated in quite a while, so I had to find a fork of the project to package with it.  I previously used Hello71's fork, but Ubuntu users pointed out that it was built with a newer version of Qt5 and wouldn't work on their system.  I ended up going to DanFritz' fork, as it still supported Qt4.

Now it looks like I will have to go back to Hello71's fork.  I've created a Ubuntu virtual machine and was able to compile DT using Qt5.5.1, which is the version that comes with the latest LTS build of Ubuntu.  I've tested this build and it does not crash when squads are present.

As soon as TWBT is updated to support DFHack 0.43.05-r2, I'll put out a new revision with Hello71's fork of DT.  In the meantime, you can download this version of DT from my dropbox:  https://www.dropbox.com/sh/af6sa2wv9v9zse1/AACB2pRWnoVpYWBn6Z_p2m3na.  Just delete the dwarf_therapist folder from LNP/utilities and drop this one in its place.
Logged

Enay

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #40 on: July 20, 2017, 12:15:43 pm »

Download HERE

If you like the work I've put into assembling this pack, please feel free to head over to my Patreon page and buy me a coffee.  Or a beer.  Or a sammich.  I'm really not picky.

To Run: Simply execute the included startlnp script.

LNP IMPORT TIPS
When first launching a new version of the LNP, you'll be asked if you want to import files from a previous installation. If you select yes, open the previous version's df_linux folder in the file chooser dialog, then click ok. Selecting the LNP folder or the root of the pack will cause the import to fail. The import process will grab your DF saves, SoundSense and/or SoundCense sounds, gamelog, and dfhack history from the previous version.

Major changes over previous revision:
  • Updated DFHack to v0.43.05-r2
  • Updated Armok Vision to v0.17.0
  • Updated Legends Browser to v1.13
  • Updated TWBT to 5.85

Minor changes over previous revision:
  • Reduced default visitor cap from 100 down to 50 to reduce possible FPS death
  • Temporarily including baseline files (PyLNP baseline downloader bugged for the moment)
  • Replaced deprecated `realpath` with `readlink -f` in a the wrapper scripts for DF Announcement filter, Dwarf Therapist, and Legends Browser
  • Removed error-causing comma from PyLNP.user (Thanks @Tymewalk)
  • Replaced Dan Fritz's fork of Dwarf Therapist with Hello71's fork due to a crash when reading dwarves while a military is in place (Thanks @Bulwersator)

Utilities included:
  • PyLNP 0.12b
  • DF 0.43.05
  • DFHack 0.43.05-r2
  • Dwarf Therapist 37.0.0 (Hello71's fork built with Qt5.5.1)
  • TWBT 5.85
  • Soundsense r2016-1 (you'll need to download the sound files yourself from within the application)
  • SoundCenSe GTK 1.4.2  (A c# audio engine for Dwarf Fortress based on Zweistein's SoundSense)  (*Requires Mono*)
  • Armok Vision 0.17.0
  • Legends Browser 1.13 (*Requires Java 8*)

Graphics packs included:
  • Afro
  • AutoReiv
  • CLA
  • GemSet
  • IronHand
  • Jolly Bastion
  • Mayday
  • Obsidian
  • Phoebus
  • Rally Ho
  • Spacefox
  • Taffer
  • Tergel
  • Wanderlust

Download HERE
« Last Edit: July 20, 2017, 12:23:45 pm by Enay »
Logged

Jathe

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #41 on: August 01, 2017, 09:33:53 am »

Not sure what I'm doing wrong but when I try to start it I get this.

Quote
travis@crunchbang:~/downloads/LinuxLNP-0.43.05-r06$ ./startlnp
[WARNING] startlnp: Could not find /sbin/getcap and/or /sbin/setcap
./PyLNP: 6: ����%ڕ!h: not found
./PyLNP: 6: NB]K: not found
./PyLNP: 6: FA_71X4:/: not found
./PyLNP: 6: 9^@WRVM[
                      SOZEL
                            : not found
./PyLNP: 6: �ah�ap�ax�a��a��a��a: not found
��a��a��a��aȲaвaزa��a��a��a��a�a�a�a�a: not found
./PyLNP: 6: �aJh�aKp�aLx�aM��aN��aO��aP��aQ��aR��aS��aU��aV��aWȴaXдaYشaZ��a[��a]��a^��a_�a: not found
./PyLNP: 6: ����%ږ!h: not found
./PyLNP: 6: �@����%ʖ!h
                      �0����%!h
                                �: not found
./PyLNP: 6: cannot create �@@x�@@'$@@@@@��@@@@ԯԯ ��a�a���  �Q�td/lib64/ld-linux-x86-64.so.2GNU GNUc*�5�}2~x�'�CaYH56(T.Q� 6�*���ص�n���>��IA��Zz��a�@��p��f�a�е��C�60�J���Y����[u�Ga�����a+>�n;��tJ�$f�B�
                                           �|0�����a����������:b2T�7libdl.so.2dlsymdlerrordlopenlibz.so.1inflateEndinflatezlibVersioninflateInit_libm.so.6sqrtlibc.so.6tolowergetenvfwritetouppermemcpystpcpyreallocvfprintfreadlinkstrcatfeofrealpathremovermdirstrcasecmpmkdtempmkdirmallocstrrchrstrlenopendir_IO_stdin_usedexecvstrncasecmpfdopensetbufwaitgetpidstdoutmemmovefclosefreadstrncatfopenfgetcstderrstrtok__libc_start_mainfilenovprintfclosedir__xpg_basenamefputcfgetsferrorstrncpyunsetenvunlinkfflushmemsetqsortmkstempmemcmpvsnprintfsprintfclearerrstdinfseekexitrenameforkraisestrstrstrcmpftellfreereaddirstrchrfchmodisspacestrdupntohlexecvpsignalstrcpykill__xstat_edata__bss_start_end__gmon_start__native_linker_pathlsb_linker_pathGLIBC_2.2.5GLIBC_2.3Wui   � �a(�a   �fii
                          0�a��a8�a%��a
                                           ��a.X�a�a(h�a)p�a*x�a+��a,�a-��a/��a0��a1��a2��a3��a4��a5ȳa6гa7سa8��a9��a:��a<��a=�a�a?�a@�aA �aB(�aC0�aD8�aE@�aFH�aGP�aHX�aIH���H���5�!�%$�!@�%�!h������%�!h������%�!h������%
�!h������%�!h������%��!h������%��!h������%��!h�p����%��!�����%Z�!h�P����%R�!h�@����%J�!h�0����%B�!h� ����%:�!h�����%2�!h�����%*�!h������%�!h: Directory nonexistent
./PyLNP: 6: ELF: not found
./PyLNP: 8: Syntax error: "(" unexpected
[WARNING] startlnp: Failed to start PyLNP
travis@crunchbang:~/downloads/LinuxLNP-0.43.05-r06$

It's probley because I'm using Crunchbang Linux 2.6.32-5-686

It's an older COMPAQ desktop that used to have WinXP Home on it, but the recovery discs never worked and it has no internet connection (I'm at the library right now), so if there is something I have to d/l I need to be able to put it on my 8gb flashdrive.

EDIT: I guess I'm missing some things, trying to find them all and download them is takeing a while, like I said I can't just enter a command and get them all at once, and I dont think the library would appreciate me bringing my whole desktop over just to use the internet, lol! I might have managed to do it, not sure yet. Would it be possible to just include these (Libraries/Binaries/Programs or whatever they are?) in the package itself for people like me who have no regular internet access?
« Last Edit: August 03, 2017, 03:03:21 pm by Jathe »
Logged

moozaad

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #42 on: September 02, 2017, 02:40:05 pm »

Bizarre issue in opensuse tumbleweed - not had it in previous versions. Therapist doesn't populate it's grid properly - it's either empty or showing the results for the wrong tab. If I keep adding tabs, eventually it'll get the right layout after about the third or fourth. Not sure if relevant but TW is on mono 5.2. There's no errors in the logs.

Also please add Meph's gfx! http://dffd.bay12games.com/file.php?id=12516

also also /usr/sbin/getcap not /sbin/getcap. `whereis getcap` returns the correct one. It seems to work fine without it --- correcting it doesn't fix the therapist issue.
Logged

Mesa

  • Bay Watcher
  • Call me River.
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #43 on: September 12, 2017, 01:03:35 am »

So I'm on Arch Linux x64 but unless I'm being the world's biggest idiot, I don't seem to have (almost) any of the utilities that are allegedly bundled with this?
The only one that seems to be there is dfannouncementfilter and even then I had to enable it by removing it from the excludes.txt list.

For all I know it's got to do with the AUR package...

Also I can't seem to be able to get a terminal to work (at least, when setting one, though I assume that extends to trying to run one 'in practice' as well) - whether it's xterm or xfce4-terminal (the one I would much prefer to get working since I'm using Xfce), I get an unknown error (which is hardly helpful).


I swear I'm fairly tech-savvy most of the time, but right now I'm largely confused here, so sorry if this is elementary knowledge that I'm just missing in a spectacular way or something...

EDIT: Alright, disregard the terminal issue (though xterm is still the one that pops up when DFHacks prompts me for a password to access DF data, but everything else seems to run with xfce-terminal). Still confused about the utilities though.
« Last Edit: September 12, 2017, 03:51:28 am by Mes »
Logged

Burneddi

  • Bay Watcher
    • View Profile
Re: LinuxLNP - 0.43.05 x64
« Reply #44 on: September 30, 2017, 07:55:56 am »

distro_fixes.sh seems to have some bug in it:
Code: [Select]
[distro_fixes] [INFO] Checking whether any distro specific fixes are required...
./distro_fixes.sh: line 57: [: /home/eru/Dwarf: binary operator expected

I think it might be related to spaces in the game folder name, as mine is /home/eru/Dwarf Fortress/LinuxLNP-0.43.05-r06/.
Logged
Pages: 1 2 [3] 4 5 ... 14