Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 6 7 [8] 9 10 11

Author Topic: LinuxLNP STABLE - 0.44.12-r01 x64  (Read 58048 times)

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #105 on: April 12, 2018, 11:45:42 am »

i'm on linux mint here, cannot start soundsense through the LNP.
which files do i have to execute manually (trying to figure out packages i might be missing)?
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

strainer

  • Bay Watcher
  • Bugeyed Goblin Artiste
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #106 on: April 12, 2018, 12:12:37 pm »

If you start the LNP from a terminal by running ./startlnp in its root: then when you doubleclick soundsense in the utilities tab you can see the messages/errors logged to the terminal.
You can also start soundsense without starting LNP, by cd'ing to /LNP/utilities/soundsense and running ./soundSense.sh
Logged
hey! pssst... a cascade is coming... keep to the caverns - your labors and dreams...

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #107 on: April 12, 2018, 12:19:13 pm »

If you start the LNP from a terminal by running ./startlnp in its root: then when you doubleclick soundsense in the utilities tab you can see the messages/errors logged to the terminal.
You can also start soundsense without starting LNP, by cd'ing to /LNP/utilities/soundsense and running ./soundSense.sh
:) thanks. found out that java wasn't installed - although it should already be... strange. reinstalling java and trying again.
EDIT: it works now. thanks.
EDIT2: soundsense now works, but DF crashes under wine... so can i just copy the contents of Mephs DF over into the linuxLNP?
« Last Edit: April 12, 2018, 01:06:28 pm by Pvt. Pirate »
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

TV4Fun

  • Bay Watcher
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #108 on: April 12, 2018, 04:33:39 pm »

For some reason, only a few of the graphics sets are being listed, even though they're all in the LNP/graphics directory. This is on Ubuntu 18.04
Spoiler (click to show/hide)
To answer my own question, I think this is because the manifests for the other graphics packs don't list themselves as compatible with 44.09. For example, the manifest for Phoebus only lists it as compatible with 44.07.
Logged

strainer

  • Bay Watcher
  • Bugeyed Goblin Artiste
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #109 on: April 12, 2018, 04:51:48 pm »

Quote from: Pvt. Pirate
can i just copy the contents of Mephs DF over into the linuxLNP
Hmm, I expect there will be a couple of config files to merge as well as the game save and graphic sets, so you could maybe compare the packs with something like winmerge or kdiff to examine differences in the init.txt type of files - ive yet to look into it all properly.

Quote from: TV4Fun
this is because the manifests for the other graphics packs don't list themselves as compatible with 44.09. For example, the manifest for Phoebus only lists it as compatible with 44.07.
Well noted TV4Fun - I didnt notice because Phoebus is the installed set, but it is missing from the custom list as well as others.
« Last Edit: April 12, 2018, 04:57:27 pm by strainer »
Logged
hey! pssst... a cascade is coming... keep to the caverns - your labors and dreams...

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #110 on: April 13, 2018, 03:48:29 am »

as long as it's only the inits, they contain little changes i can easily do manually - i 'm rather afraid if the changes in the raws will be compatible with the new game version. (mephs is 44.07 and LNP 44.09)
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #111 on: April 16, 2018, 01:34:21 pm »

i used your LNP (and finally got it up and running), checked and it worked. then made a copy and then migrated the raws, art and init from my previous mephs-pack in. just saw this:
"Can't load plugin 3dveins
TWBT: version 6.41
TWBT: no display patch (not an error)
Can't load plugin stonesense
Can't load plugin rendermax
"
i don't knwo 3dveins... didn't knwo i activated it either. maybe yopying mephs in there might have it listed.
not using stonesense here.
whats rendermax?
will this conflict?
main screen loaded fine. creating a world now...
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

lethosor

  • Bay Watcher
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #112 on: April 16, 2018, 01:39:23 pm »

Can you post the contents of your stderr.log file?
Are you saying that you copied over 3dveins/rendermax from Meph's pack?
All plugins are loaded when DFHack starts, which is when the messages you see are being printed. You don't have to do anything to make that happen, and they will be loaded even if they are disabled (in fact, they are all disabled until something enables them, like dfhack.init or someone running commands at the console).
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #113 on: April 16, 2018, 03:43:26 pm »

i don't know why, but on the second try it just worked without error.
erm stderr.log is too big now... played1 hour...
i'll upload a log with only until main menu.
no, i didn't copy in any dfhack stuff.
« Last Edit: April 16, 2018, 03:46:52 pm by Pvt. Pirate »
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

Lohakar

  • Bay Watcher
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #114 on: April 19, 2018, 02:33:01 am »

I tried this "pack" last Sunday.
I chose a place on the edge of the polar region. Frozen lake, two frozen rivers. All the year! Ice never thaw. No liquid water.
I like it. No wood, penguins, skates, winter sports, icecream all the year, you know :-)

To my BIG surprise this map was full of differents trees. Ok, but... Persimmons, chestnuts, honeybees, termites!
Hm. Life from "Any temperate" and surface water from "Freezing" .
Hm. Procedurally generated climate, maybe...


A small question:
A am able to pick and collect persimmons, acorns, but chestnut burrs remain intact.
Why?
What I am doing wrong?
Logged

dan84

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #115 on: April 25, 2018, 06:31:20 pm »

Linux Mint 18.3 x86_64
Running PyLNP 0.13 (OS: linux, Compiled: True)
LinuxLNP-0.44-09-r01

Two things to note:

1.  Many of the graphics packs are only set for a max version 0.44.07 and so will not show up when the game is run.  I had to go into the LNP/graphics directory and modify each pack's manifest.json to 0.44.09.  Does simply removing the max version also work?
2.  stonesense does not work (P.S. this is the likely root cause of Pvt. Pirate's problem above).  Looking at df_hack/stderr.log, I see
/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/dan/Games/LinuxLNP-0.44.09-r01/df_linux/hack/plugins/stonesense.plug.so)

This is the std C library used by most of the Debian-based linux distros (Ubuntu, Mint, etc).  It means stonesense was compiled with the 2.27 version of GLIBC.  Most Ubuntu and Mint distros are built with older versions:
mine, for example (mint is based on ubuntu):
ldd --version
ldd (Ubuntu GLIBC 2.23-0ubuntu10) 2.23

Not sure what the way forward is, but whomever is compiling stonesense, it would be good if you could compile it with an older compiler.  I am not sure what the recommendation is, but someone is going to have to recompile it.  If I do, can I just add it into df_linux?
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #116 on: April 25, 2018, 11:09:38 pm »

BenLubar is aware of the issue and the GCC 4.8 build of DFHack will be more compatible in the next version: https://github.com/Lazy-Newb-Pack/Lazy-Newb-Pack-Linux/issues/52#issuecomment-384182937 . It's actually because he's building on a newer Ubuntu (18.04), although if this pack distributes the GCC 7 build, that could be problematic.

Can you tell what version of GCC yours was built with? At the very least, running libdfhack.so through strings should give some GCC paths. Either 4.8 or 7.3 (7.2? 7?) should show up somewhere.

Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Pvt. Pirate

  • Bay Watcher
  • Dabbling Linux User
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #117 on: April 26, 2018, 05:15:52 am »

Linux Mint 18.3 x86_64
Running PyLNP 0.13 (OS: linux, Compiled: True)
LinuxLNP-0.44-09-r01

Two things to note:

1.  Many of the graphics packs are only set for a max version 0.44.07 and so will not show up when the game is run.  I had to go into the LNP/graphics directory and modify each pack's manifest.json to 0.44.09.  Does simply removing the max version also work?
2.  stonesense does not work (P.S. this is the likely root cause of Pvt. Pirate's problem above).  Looking at df_hack/stderr.log, I see
/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/dan/Games/LinuxLNP-0.44.09-r01/df_linux/hack/plugins/stonesense.plug.so)

This is the std C library used by most of the Debian-based linux distros (Ubuntu, Mint, etc).  It means stonesense was compiled with the 2.27 version of GLIBC.  Most Ubuntu and Mint distros are built with older versions:
mine, for example (mint is based on ubuntu):
ldd --version
ldd (Ubuntu GLIBC 2.23-0ubuntu10) 2.23

Not sure what the way forward is, but whomever is compiling stonesense, it would be good if you could compile it with an older compiler.  I am not sure what the recommendation is, but someone is going to have to recompile it.  If I do, can I just add it into df_linux?
hmmm i still don't understand enough about linux to see how i could get stonesense to run, but obviously the dfhack-plugin for stonesense is causing some of the problems.
« Last Edit: April 26, 2018, 05:17:56 am by Pvt. Pirate »
Logged
"dwarves are by definition alcohol powered parasitic beards, which will cling to small caveadapt humanoids." (Chaia)

dan84

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #118 on: April 26, 2018, 08:27:35 am »

BenLubar is aware of the issue and the GCC 4.8 build of DFHack will be more compatible in the next version: https://github.com/Lazy-Newb-Pack/Lazy-Newb-Pack-Linux/issues/52#issuecomment-384182937 . It's actually because he's building on a newer Ubuntu (18.04), although if this pack distributes the GCC 7 build, that could be problematic.

Can you tell what version of GCC yours was built with? At the very least, running libdfhack.so through strings should give some GCC paths. Either 4.8 or 7.3 (7.2? 7?) should show up somewhere.

$ strings -a libdfhack.so | grep GCC
GCC_3.0
GCC: (Ubuntu 4.8.5-4ubuntu8) 4.8.5
_Unwind_Resume@@GCC_3.0

libc on my box:
$ /lib/x86_64-linux-gnu/libc.so.6
GNU C Library (Ubuntu GLIBC 2.23-0ubuntu10) stable release version 2.23, by Roland McGrath et al.

dfhack executable:
~/Games/LinuxLNP-0.44.09-r01/df_linux/hack$ strings -a dfhack-run | grep GLIBC
GLIBCXX_3.4
GLIBC_2.2.5
GLIBC_2.3.4

stonesense itself:~/Games/LinuxLNP-0.44.09-r01/df_linux/hack/plugins$ strings -a stonesense.plug.so | grep GLIBC
GLIBC_2.27
GLIBC_2.2.5
GLIBC_2.4
GLIBC_2.3.4
GLIBC_2.3
GLIBC_2.14
GLIBCXX_3.4.9
GLIBCXX_3.4.11
GLIBCXX_3.4


Logged

dan84

  • Escaped Lunatic
    • View Profile
Re: LinuxLNP STABLE - 0.44.09-r01 x64
« Reply #119 on: April 26, 2018, 08:30:50 am »

hmmm i still don't understand enough about linux to see how i could get stonesense to run, but obviously the dfhack-plugin for stonesense is causing some of the problems.

You can't (without some advanced linux understanding) until it gets compiled differently.  The problem is that whomever is building this distribution is using more modern libraries that what we have on our distros of ubuntu and mint.

Another solution might be to stick this whole build on github or bitbucket or something and let us build it from source on our own machines.
Logged
Pages: 1 ... 6 7 [8] 9 10 11