Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 40 41 [42] 43 44 ... 60

Author Topic: Dwarf Therapist v41.1.7 | DF 47.04  (Read 167631 times)

feelotraveller

  • Bay Watcher
  • whip cracking mad overseer
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #615 on: February 22, 2019, 12:37:06 am »

Clément perhaps you could add to my reply here?  :)

http://www.bay12forums.com/smf/index.php?topic=173319.0
Logged

Clément

  • Bay Watcher
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #616 on: February 23, 2019, 06:18:27 am »

There is no macOS build after Qt 5.5 was removed from homebrew because it does not work with the latest version of macOS. The easiest fix would be to use the only version of Qt available in homebrew. That would be the latest: 5.12, DT would require at least macOS 10.12 Sierra (current minimum version is 10.9). In order to support older macOS version, it would require multiple builds. Is it worth it and does any one know another source for Qt that could be use in Travis?
Logged

feelotraveller

  • Bay Watcher
  • whip cracking mad overseer
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #617 on: February 27, 2019, 01:46:50 am »

My two cents, since there is no other feedback, is that it is good to have versions for all OS's.  Failing that instructions clear enough that the generic newer user can build it for themselves.  And as a failsafe (or if it is not worth the effort to maintain various versions): links to last/latest working therapist for various macOS versions.

But perhaps it is up to the Mac community to provide some assistance...

Chances are it will become an issue during a major update, right when other things are pressing.  ;)
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #618 on: July 30, 2019, 09:01:50 pm »

Clement was assisting me with a non clean personal system.  So I wanted to do justice and retry with a clean vm

qt 5.13
using the gnu32 included
cmake32
made this change in the cmakelist.txt
setup the kit to use gnu32

target_link_libraries(${EXE_NAME} Qt5::Widgets Qt5::Qml Qt5::Concurrent Qt5::Core Qt5::Gui Qt5::Network ${LIBS})

I get a message about failing to compile a simple program with gcc

So... I tried the 64 bit versions of gnu and cmake.  Same issue.

stuck.

:(

git repo: https://github.com/cvuchener/Dwarf-Therapist.git
« Last Edit: July 31, 2019, 09:13:13 am by thistleknot »
Logged

Clément

  • Bay Watcher
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #619 on: July 31, 2019, 03:12:34 am »

There should be another error message explaining why the simple test program compilation failed.

I get this message because I have a non-ASCII character in my username, and cmake fails to find the temp directory because of encoding issues.
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #620 on: July 31, 2019, 11:44:16 am »

what version of cmake and gnu should I be using?  Last instructions I had were gnu32.  But what about cmake?

Error I get with cmake64 and gnu32 (see the conundrum?). I'm on x64 windows

Last instructions I had was gnu32.

what's installed

https://imgur.com/a/1GeZr7w

kit confiugration

https://imgur.com/a/gYpfX8D

one line change to cmakelist

https://imgur.com/a/J2lrs3g

Error upon configuring

https://imgur.com/a/DhKBRUI

Spoiler (click to show/hide)


Clément

  • Bay Watcher
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #621 on: July 31, 2019, 12:07:34 pm »

Try changing the kit to use "MinGW Makefiles" generator. I don't understand why this is not automatically configured. NMake is for MSVC.
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #622 on: July 31, 2019, 12:41:25 pm »

Kit

https://imgur.com/a/KK6KUOU

different error about cmake

Spoiler (click to show/hide)

Clément

  • Bay Watcher
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #623 on: July 31, 2019, 01:07:19 pm »

I did not see it was a manually created kit. Then you need to manually configure everything, especially the "Qt Version" part. But usually the qt sdk is auto-detected and you only have to configure cmake.
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #624 on: July 31, 2019, 01:26:42 pm »

It's not a manually created kit.  That was the default one.  I only made changes to it.  Do you have a screenshot of your kit?

It's under "manual" but I did not create that kit.  I suppose it's failing to auto detect one and therefore creates a manual one?  Either way.  I'm at a loss.  I installed QT software, why doesn't it have a default auto detected kit?

Clément

  • Bay Watcher
    • View Profile
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #626 on: July 31, 2019, 02:36:32 pm »

I think I know what the issue was.

I didn't select any QT anything.

I thought I just needed the mingw under the "Developer and Designer Tools"

This is now my installation setup.

https://imgur.com/a/4SWnYGP
https://imgur.com/a/oe8kWSD

thank goodness

Spoiler (click to show/hide)

looks like it's building now,

will report on if it runs :)
« Last Edit: October 13, 2019, 07:49:22 pm by thistleknot »
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #627 on: July 31, 2019, 04:18:43 pm »

project builds but unable to detect df

similar issue to what I was experiencing on laptop, but not the exact same.  I'm getting less errors. I see a tls error (not on screen, but within dt in lower right)

https://imgur.com/a/MuwSaPy

I didn't select that debug option you recommended before.  I simply ran it
« Last Edit: July 31, 2019, 04:35:24 pm by thistleknot »
Logged

Clément

  • Bay Watcher
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #628 on: July 31, 2019, 05:19:41 pm »

If it is because of missing memory layouts, you should check BUILD_DEVMODE in cmake options (don't forget to apply) and rebuild, or copy the "share" folder next to the executable and rename it "data". If it is another issue you will need to check the log.

Don't worry about the ssl error, it is the updater but you don't need it.
Logged

thistleknot

  • Bay Watcher
  • Escaped Normalized Spreadsheet Berserker
    • View Profile
Re: Dwarf Therapist v41.0.3 | DF 44.12
« Reply #629 on: July 31, 2019, 07:47:37 pm »

put on devmode

https://imgur.com/a/u50YaN0

cleaned project, rebuilt

copied share (tried mw mode first,then I tried the one in the Dwarf-Therapist folder).  Still throws same error.

https://imgur.com/a/SonEmew

looked at log and it appears to find the process, but can't match a memory layout.  Going to try with standard dwarf fortress (vs MW)

Spoiler (click to show/hide)


« Last Edit: July 31, 2019, 07:50:29 pm by thistleknot »
Logged
Pages: 1 ... 40 41 [42] 43 44 ... 60