Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: designate to dig tile problem  (Read 306 times)

Apostolos

  • Bay Watcher
    • View Profile
designate to dig tile problem
« on: January 05, 2018, 12:39:26 pm »

I started this back up today after a good long while and immediately ran into a problem I do not remember seeing before. On embark I tried to designate a dig area to get started and it showed the exposed tiles in green for digging, but the 'hallway' I was trying to designate into the mountain was still black.  The dwarves did dig it out but I could not tell what I had designated and what was still just the black tiles. It used to show a tan blueprint of where to dig so you could plan out a large area to dig. Now I just cannot see what is designated anymore. Ive been searching the problem to no avail so far if anyone knows what I am missing.

Thanks.
Logged

jecowa

  • Bay Watcher
    • View Profile
Re: designate to dig tile problem
« Reply #1 on: January 05, 2018, 04:02:14 pm »

What tileset are you using? Are you using a Lazy Newb Pack? If so, which version?
Logged

Apostolos

  • Bay Watcher
    • View Profile
Re: designate to dig tile problem
« Reply #2 on: January 05, 2018, 04:56:11 pm »

sorry I did not reply sooner. I had been messing around with this for a bit and kinda gave up. I started the pc later to fiddle with it some more and the issue just went away. (using LNP I just downloaded today r11) I guess I hit some button that changed something.  The exposed tiles to dig out were still green but using X to 'un-designate' them and then d to set them to be dug out and they are now turning the normal tan color.  *shrug*  No idea what I did..just dwarf science at work.
Logged

el Indio

  • Bay Watcher
    • View Profile
Re: designate to dig tile problem
« Reply #3 on: January 06, 2018, 02:43:15 am »

It sounds like you may have toggled "automine" on.
Logged

jecowa

  • Bay Watcher
    • View Profile
Re: designate to dig tile problem
« Reply #4 on: January 06, 2018, 05:06:48 am »

Is automine a vanilla or a DFHack feature?
Logged

Loci

  • Bay Watcher
    • View Profile
Re: designate to dig tile problem
« Reply #5 on: January 06, 2018, 04:03:40 pm »

Is automine a vanilla or a DFHack feature?

Both. Automine was originally a DFHack enhancement, but Toady added a slightly different vanilla implementation in v0.40.20. The vanilla implementation, enabled with 'a' on the designation menu, closely matches the behavior described by the OP.
Logged