Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Help, Constant Crash on Embark  (Read 1866 times)

Mossybacon

  • Escaped Lunatic
    • View Profile
Help, Constant Crash on Embark
« on: February 01, 2019, 03:25:57 am »

Hi all, trying to get started with Masterwork but after generating worlds and finding a good spot, I always get a crash just after the embark blurb. I've looked at things like CPU and memory usage but it continues to crash no matter what I try. Not sure what else to do.

Here are my settings (plus a pic of when it crashes, after I press enter):

https://imgur.com/a/OQIyNN2

Also, there is an errorlog.txt, don't know if its normal but here it is:

http://www.mediafire.com/file/i6x6icb013h65l0/errorlog.txt/file

Any help would be appreciated.
Logged

saints_blizzard

  • Escaped Lunatic
    • View Profile
Re: Help, Constant Crash on Embark
« Reply #1 on: February 15, 2019, 01:33:12 am »

Hey! Took me some time to get a reply out to you, with making a new account and all.

I thought you should know I had this exact problem, pressing enter at the embark fluff would crash my game, came here in search of answers and saw your post, jumped for joy only to find out no one really even took the time to help you.

But, I managed to find a "fix". Not a real fix but hey, it works.

Try downloading the 1.30 version of masterwork DF, and delete your old versions of DF. If I recall correctly you will have a dwarf fortress that is a few versions younger but nothing too drastical.

I have done this myself and have been playing happily ever since... Well, "happily" since my first fortress got downed in the first year due to asp's and zombies, and my expedition leader thinking it a good idea to take a dive of the bridge at day 6... But its been loads of fun, and I can actually embark!

Hope this also works for you, if not, I hope some people with a bit more technical know-how can find an actual fix for this problem!

Edit: when I say old versions I'm referring to the current DF on your computer, which is actually probably a newer version.
« Last Edit: February 15, 2019, 03:16:00 am by saints_blizzard »
Logged

thecrimsonbeard

  • Bay Watcher
    • View Profile
Re: Help, Constant Crash on Embark
« Reply #2 on: February 15, 2019, 07:25:15 am »

Thank you saints blizzard.  Like OP, I was also having a rough time with all sorts of weird issues that I listed in my own thread.  I didn't want to start downloading every version to see if any would work for me, but 1.30 is working (so far).  While I still can't seem to load profiles or restore them to default, the actual game play doesn't seem to be giving me issues.
Logged

Lottanubs

  • Bay Watcher
  • [DF_JOKE]
    • View Profile
Re: Help, Constant Crash on Embark
« Reply #3 on: February 16, 2019, 02:08:33 pm »

I had the same problem. Infuriatingly, it doesn't seem to be consistent. The world the version comes with doesn't have the issue, and some I've had defautly generated pocket- and small-worlds work without issue. Yet my larger Perfect Worlds crash on embark. Odd, but at least there's a workaround for me.
Logged

Stalin Was a Gamer

  • Escaped Lunatic
    • View Profile
Re: Help, Constant Crash on Embark
« Reply #4 on: March 22, 2019, 08:56:05 pm »

Having the same issue.  I tried Lottanubs' thing and used a smaller size world and it worked.
Logged

Ethelt

  • Escaped Lunatic
    • View Profile
Re: Help, Constant Crash on Embark
« Reply #5 on: July 25, 2019, 07:23:19 am »

I had the same problem, but my logs were different. I decided to leave this comment for anyone struggling with it in the future. I had to embark on different spot using "Play Now" option and retire the fort. Then I could embark normally wherever I wanted.
Logged