Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: LCS on raspberry pi  (Read 1247 times)

Linuxguy

  • Escaped Lunatic
    • View Profile
LCS on raspberry pi
« on: April 03, 2019, 10:20:41 pm »

Greetings everyone. Thank you to all the developers for this game. Has anybody compiled a working copy of LCS on a raspberry Pi? I have! On a raspbian stretch (2018) but only SVN revision 652 worked flawlessly. When trying to compile higher versions like that of 4.07.5beta or 4.10.0, yes, it compiles and sound even works however I encounter problems with the interface. (The latest versions does not even compile for me.) Here are photos of my compiled 4.10.0 Same problem as 4.07.5beta :( As you can see, something is wrong with the text and I cant for the life of me, figure it out. Can anyone help me? I would love to play a higher version LCS with music. Best regards to everyone.
« Last Edit: April 04, 2019, 04:16:04 am by Linuxguy »
Logged

The Cheshire Cat

  • Bay Watcher
    • View Profile
Re: LCS on raspberry pi
« Reply #1 on: April 04, 2019, 09:28:03 pm »

I don't really know anything about Raspberry Pi but it seems like the issue is that it's having problems parsing the XML data. Does the version that works use externalized data or is it all hard-coded (I know at one point everything was hard-coded but I don't know when the shift over to XML data was done)? Does Raspberry Pi maybe use a weird library for parsing XML files? Alternatively, does the file formatting need to be changed to be compatible? There may be some kind of conversion that the base files need to be run through in order to parse correctly.
Logged
LCS Graphical Remake:

https://the-cheshire-cat.itch.io/lcs
Current progress: ~100%

Linuxguy

  • Escaped Lunatic
    • View Profile
Re: LCS on raspberry pi
« Reply #2 on: April 05, 2019, 12:14:40 am »

Greetings Cheshire Cat. Thank you for your insight. The versions which worked were the ones under Revision 732. In that revision, a change in XML was introduced so you are right, most likely the problem is along that subject. Raspberry stretch comes with a library for XML parsing of C called libexpat1/libexpat1-dev. However I have no idea how to do file formatting for these. Would this help by any chance? https://pastebin.com/rnSph4JN (config.log)
« Last Edit: April 05, 2019, 06:32:34 am by Linuxguy »
Logged