Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Crash on save (adventure mode)  (Read 2587 times)

Jack_Caboose

  • Bay Watcher
  • Lurker Supreme
    • View Profile
Crash on save (adventure mode)
« on: August 06, 2019, 03:12:19 pm »

Whenever I save an adventure mode game on a large world, it crashes. It works fine on medium (and presumably smaller) worlds, though. Is there any way to fix or should I just wait for the next update?

Jack_Caboose

  • Bay Watcher
  • Lurker Supreme
    • View Profile
Re: Crash on save (adventure mode)
« Reply #1 on: August 08, 2019, 12:55:30 am »

I think I have somewhat narrowed the issue - sometimes, on world generation, if I try to use dfhack's "exportlegends info" command, it will crash upon generating the legends_plus file. The file works as usual but stops halfway through an artifact entry (usually a book, but not always) and crashes DF. So I tried to look through the artifacts section in DF legends itself, which also led to a crash. I guess this only affected larger worlds because what ever material/item is causing the corrupt artifacts is given more chance to be used. Is there any way to find out which artifacts are causing this issue? If it's a specific creature's leather or something, I could always try deleting that creature from the raws.

KristoffPL

  • Escaped Lunatic
    • View Profile
Re: Crash on save (adventure mode)
« Reply #2 on: November 08, 2019, 07:14:31 am »

Same thing is happening to me, whenever I try to save my Adventurer mode game it just crashes, no matter what I do. I don't know if it's related, but in Fortress mode I get crashes when I try to abandon a fort, it keeps happening on the "offloading units" part of the procedure. I have no idea what causes it, and I was not able to produce any workaround for this.
Logged

Jack_Caboose

  • Bay Watcher
  • Lurker Supreme
    • View Profile
Re: Crash on save (adventure mode)
« Reply #3 on: November 16, 2019, 01:32:27 am »

Same thing is happening to me, whenever I try to save my Adventurer mode game it just crashes, no matter what I do. I don't know if it's related, but in Fortress mode I get crashes when I try to abandon a fort, it keeps happening on the "offloading units" part of the procedure. I have no idea what causes it, and I was not able to produce any workaround for this.

Try checking your errorlog.txt and seeing if there's anything there - fixing those errors fixed all fort mode crashes for me as well as most adventure mode ones. I think it's possible we use a weird combination of settings that create an error when used together.