Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Wiki problem  (Read 7591 times)

Urist McBaywatcher

  • Escaped Lunatic
    • View Profile
Wiki problem
« on: November 27, 2019, 09:08:03 am »

Anyone else have a problem with the wiki not loading properly at all?
Logged

Silverwing235

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #1 on: November 27, 2019, 03:58:01 pm »

....similar to the sidebar straight up blanking out from time to time, particularly here, you mean? (also had a crash mid-edit with v. suspicious MediaWiki-style font....not sure if or how related. Hasn't repeated, though.)
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #2 on: December 10, 2019, 10:44:33 pm »

I can't say I've noticed this ordinarily. Can you be more specific about what you're seeing?

I did just get a "DF2014:Adventurer_mode:1 Failed to load resource: net::ERR_HTTP2_PROTOCOL_ERROR" message when visiting that adventurer mode page, though (but seeing as how clicking on that link worked perfectly fine for me roughly 19/20 times, it's helpful if you can give a screenshot or description of what you're seeing).

If you're using Chrome and encounter an issue like this again, could you open the JavaScript console (ctrl-shift-J, or cmd-alt-J on macOS) and copy any messages that you see to here?
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

lethosor

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #3 on: December 10, 2019, 11:08:36 pm »

Ok, I think we figured out what the issue was (a log on the main server had grown to take up all of the free disk space...). The other servers were functioning normally, so the issue only occurred sometimes. If you were seeing weird fonts, that was probably because that specific server was the one trying to send styles/scripts to you (and failing), so hopefully that's fixed now too. Feel free to follow up if you notice anything else out of the ordinary.
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Silverwing235

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #4 on: December 17, 2019, 08:14:53 am »

Do please note that some of us prefer Firefox, but yeah, I can certainly paste Javascript easily enough.

That aside, we now seem to have idiosyncratic 404s popping up when links are kicked clicked on, alongside a bizarre habit of occasional 'plaintexting' (boldtext w/o normal UI) that all takes quite a lot of page refreshing to make go away. Thoughts? (other than my initial suspicion being gremlins pulling levers, of course  ;D)   

EDIT: Furthermore, something just happened - unsure if relevant, but whatever:
Code: [Select]
Refreshing device list failed.
Object { error: Exception, errorString: "[Exception... \"NS_ERROR_UNKNOWN_HOST\"  nsresult: \"0x804b001e (NS_ERROR_UNKNOWN_HOST)\"  location: \"JS frame :: resource://services-common/rest.js :: onStopRequest :: line 488\"  data: no]", message: null, code: null, errno: null, toString: toString() }
browser-sync.js:249:15
Refreshing device list failed.
Exception { name: "NS_ERROR_NET_TIMEOUT", message: "Aborting due to channel inactivity.", result: 2152398862, filename: "resource://services-common/rest.js", lineNumber: 384, columnNumber: 0, data: null, stack: "abortTimeout@resource://services-common/rest.js:384:18\nnotify@resource://services-common/utils.js:175:20\n", location: XPCWrappedNative_NoHelper }
browser-sync.js:249:15
Refreshing device list failed.
Exception { name: "NS_ERROR_NET_TIMEOUT", message: "Aborting due to channel inactivity.", result: 2152398862, filename: "resource://services-common/rest.js", lineNumber: 384, columnNumber: 0, data: null, stack: "abortTimeout@resource://services-common/rest.js:384:18\nnotify@resource://services-common/utils.js:175:20\n", location: XPCWrappedNative_NoHelper }
browser-sync.js:249:15
Refreshing device list failed.
Object { error: Exception, errorString: "[Exception... \"NS_ERROR_UNKNOWN_HOST\"  nsresult: \"0x804b001e (NS_ERROR_UNKNOWN_HOST)\"  location: \"JS frame :: resource://services-common/rest.js :: onStopRequest :: line 488\"  data: no]", message: null, code: null, errno: null, toString: toString() }
browser-sync.js:249:15
Refreshing device list failed.
Object { error: Exception, errorString: "[Exception... \"NS_ERROR_UNKNOWN_HOST\"  nsresult: \"0x804b001e (NS_ERROR_UNKNOWN_HOST)\"  location: \"JS frame :: resource://services-common/rest.js :: onStopRequest :: line 488\"  data: no]", message: null, code: null, errno: null, toString: toString() }
browser-sync.js:249:15
Refreshing device list failed.
Object { error: Exception, errorString: "[Exception... \"NS_ERROR_UNKNOWN_HOST\"  nsresult: \"0x804b001e (NS_ERROR_UNKNOWN_HOST)\"  location: \"JS frame :: resource://services-common/rest.js :: onStopRequest :: line 488\"  data: no]", message: null, code: null, errno: null, toString: toString() }
browser-sync.js:249:15
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
Error: WebExtension context not found! ExtensionParent.jsm:1229:13
[Exception... "Favicon at "https://forum.rpg.net/favicon.ico" failed to load: Not Found."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 236"  data: no] FaviconLoader.jsm:236:22
Error: WebExtension context not found! ExtensionParent.jsm:1229:13
TypeError: this._timeouts.remove is not a function
BrowserUsageTelemetry.jsm:304:24
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
TypeError: this._timeouts.remove is not a function
5 BrowserUsageTelemetry.jsm:304:24
Error: WebExtension context not found! 2 ExtensionParent.jsm:1229:13
TypeError: this._timeouts.remove is not a function
BrowserUsageTelemetry.jsm:304:24
1576593642036 Toolkit.Telemetry ERROR TelemetrySend::sendPersistedPings - failed to send ping 97ad614e-fcec-4773-8de9-a0a1773bf857: {"name":"PingReadError","message":"","stack":"PingReadError@resource://gre/modules/TelemetryStorage.jsm:80:15\nloadPingFile@resource://gre/modules/TelemetryStorage.jsm:1847:13\n","becauseNoSuchFile":true} Log.jsm:723
TypeError: this._timeouts.remove is not a function
BrowserUsageTelemetry.jsm:304:24
TypeError: this._timeouts.remove is not a function
BrowserUsageTelemetry.jsm:304:24
 
 
« Last Edit: December 17, 2019, 09:46:07 am by Silverwing235 »
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #5 on: December 17, 2019, 05:50:32 pm »

Do please note that some of us prefer Firefox, but yeah, I can certainly paste Javascript easily enough.
I wasn't sure what the shortcut for Firefox was off the top of my head (I think it's ctrl-shift-J too, but wasn't confident enough to post it without checking)

Quote
That aside, we now seem to have idiosyncratic 404s popping up when links are kicked clicked on, alongside a bizarre habit of occasional 'plaintexting' (boldtext w/o normal UI) that all takes quite a lot of page refreshing to make go away. Thoughts? (other than my initial suspicion being gremlins pulling levers, of course  ;D)   
Definitely weird. I'm investigating. How recently did this start happening? Seems to be isolated to one server at the moment...

Quote
EDIT: Furthermore, something just happened - unsure if relevant, but whatever:
Spoiler (click to show/hide)

I've never seen any of these messages before. Where did they come from? (I don't think they're relevant either, but context would help.)


Edit: it seems to have magically fixed itself. Unfortunately, due to how the server is set up, I can't figure out what was going wrong then, so continue to let me know if you see this happen again.
« Last Edit: December 17, 2019, 06:13:38 pm by lethosor »
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.

Silverwing235

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #6 on: December 17, 2019, 06:25:04 pm »

Do please note that some of us prefer Firefox, but yeah, I can certainly paste Javascript easily enough.
I wasn't sure what the shortcut for Firefox was off the top of my head (I think it's ctrl-shift-J too, but wasn't confident enough to post it without checking)

Quote
That aside, we now seem to have idiosyncratic 404s popping up when links are kicked clicked on, alongside a bizarre habit of occasional 'plaintexting' (boldtext w/o normal UI) that all takes quite a lot of page refreshing to make go away. Thoughts? (other than my initial suspicion being gremlins pulling levers, of course  ;D)   
Definitely weird. I'm investigating. How recently did this start happening? Seems to be isolated to one server at the moment...

Quote
EDIT: Furthermore, something just happened - unsure if relevant, but whatever:
Spoiler (click to show/hide)

I've never seen any of these messages before. Where did they come from? (I don't think they're relevant either, but context would help.)

In no particular order, if ctrl-shift-J is the jscript console shortcut for Firefox, the codeblock of messages would be its output roughly when weirdness started happening, although it seems to be more consistent with people trying to pull up previews when they save their edits, and editors editing in general. A more useful source of coordination/correlation, I think - at least where I first encountered discussion myself.
Logged

Silverwing235

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #7 on: March 30, 2020, 07:59:32 am »

Again with plaintexting shenanigans on pages, plus this:

Quote from: wiki message
Sorry! This site is experiencing technical difficulties.

Try waiting a few minutes and reloading.

(Cannot access the database: Cannot access the database: Unknown error (127.0.0.1)) 

Anyone?
Logged

lethosor

  • Bay Watcher
    • View Profile
Re: Wiki problem
« Reply #8 on: March 30, 2020, 07:56:08 pm »

Hard drive on one of the servers filled up again :/
Restarted, looks good to me now, should be good for another... 3 months at this rate? I'll try to find a better fix.
Thanks for reporting!
Logged
DFHack - Dwarf Manipulator (Lua) - DF Wiki talk

There was a typo in the siegers' campfire code. When the fires went out, so did the game.