Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4

Author Topic: Moss not growing  (Read 1243 times)

FantasticDorf

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #30 on: February 13, 2020, 04:44:26 pm »

Downloaded it and tested. The lack of moss growth is related to the depth of the caverns somehow. On z13, I dug northwest from the central staircase to the visible moss and received a caverns-found message, then moss began growing everywhere.

Oh yeah that sounds dead-on bug, get that save showcased asap.
Logged

anewaname

  • Bay Watcher
  • The mattock... My choice for problem solving.
    • View Profile
Re: Moss not growing
« Reply #31 on: February 13, 2020, 11:23:26 pm »

In this image, you can see he built a wall adjacent to moss in the cavern area.


So, something buggy stopped the moss from growing, but it may be due to modified raws or the like.
Logged

Dracko81

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #32 on: February 14, 2020, 12:33:13 am »

In this image, you can see he built a wall adjacent to moss in the cavern area.


So, something buggy stopped the moss from growing, but it may be due to modified raws or the like.

The wall was built to stop/slow things coming up.  Actually the 3 walls further along were built because I mined the walls trying to trigger spores.

No modding was done.
Logged

Dracko81

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #33 on: February 14, 2020, 12:42:46 am »

Downloaded it and tested. The lack of moss growth is related to the depth of the caverns somehow. On z13, I dug northwest from the central staircase to the visible moss and received a caverns-found message, then moss began growing everywhere.

I don't see any moss on z13, I don't see any caverns above z17.  Maybe I'm reading the z wrong.
Logged

anewaname

  • Bay Watcher
  • The mattock... My choice for problem solving.
    • View Profile
Re: Moss not growing
« Reply #34 on: February 14, 2020, 04:38:35 am »

In that last post, I was just trying to point out to FantasticDorf that something was buggy, because there was moss adjacent to a wall you built. That should have caused cavern exposure.

In your embark, the F4 hotkey brings you to this level and I just dug a corridor to the two plump helmets (the purple ":" symbols to the northwest). That generated a new "found a cavern" message for me. The z level is the 13 in the lower right of the image.
Spoiler (click to show/hide)
Logged

Dracko81

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #35 on: February 14, 2020, 01:17:35 pm »

I dug across to that spot and it triggered for me too.  (That is the F5 level fyi)

But that is just so strange again since I've mined out other exits on that same level.
Logged

PatrikLundell

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #36 on: February 14, 2020, 01:31:35 pm »

I dug across to that spot and it triggered for me too.  (That is the F5 level fyi)

But that is just so strange again since I've mined out other exits on that same level.
A thought: is the new exit in a different biome (on the surface) from the others (not that is any less buggy, but it would sort of explain why the cavern is "breached" again)?
Logged

Dracko81

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #37 on: February 14, 2020, 01:51:58 pm »

I dug across to that spot and it triggered for me too.  (That is the F5 level fyi)

But that is just so strange again since I've mined out other exits on that same level.
A thought: is the new exit in a different biome (on the surface) from the others (not that is any less buggy, but it would sort of explain why the cavern is "breached" again)?
No the fort is in a single biome from what I can tell, I retired the fort and there was no different biomes in the area.  There is a swamp biome to the NW of the fort but this breach wasn't in the NW.  Getting 2 expansive caverns reports for a single cavern is strangle non-the-less.  Let alone breaching and not getting spores and having a 90+ z-level cavern.
Logged

Pancakes

  • Bay Watcher
  • Cancels drink: Too insane
    • View Profile
Re: Moss not growing
« Reply #38 on: February 14, 2020, 02:11:38 pm »

I actually encountered this a while back (34.11 I think) and I solved it by digging a few more entrances into the caverns, as you have. It's a minor bug, for sure, but it can still be a nuisance, particularly for new players.
Logged
Sigging yourself is poor etiquette.

Shonai_Dweller

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #39 on: February 14, 2020, 05:51:56 pm »

I actually encountered this a while back (34.11 I think) and I solved it by digging a few more entrances into the caverns, as you have. It's a minor bug, for sure, but it can still be a nuisance, particularly for new players.
And until someone posts a save which demonstrates it,  it will remain a nuisance for another 10 years (or most likely until the map rewrite).
http://www.bay12games.com/dwarves/mantisbt/view.php?id=11303
Logged

Blue_Dwarf

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #40 on: February 14, 2020, 06:42:47 pm »

Now, how do we weaponize this?
Logged
Crafting Statistics 42.06Farming Statistics

Blue Dwarf has been happy lately. He did some !!science!! recently. He admired a fine forum post lately. He was enraged by a forum troll recently. He was upset by the delayed release of the new version of Dwarf Fortress lately. He took joy in planning a noble's death recently.

anewaname

  • Bay Watcher
  • The mattock... My choice for problem solving.
    • View Profile
Re: Moss not growing
« Reply #41 on: February 14, 2020, 09:19:28 pm »

...
And until someone posts a save which demonstrates it,  it will remain a nuisance for another 10 years (or most likely until the map rewrite).
http://www.bay12games.com/dwarves/mantisbt/view.php?id=11303
The links and info have been posted to mantisbt.
Logged

Ant

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #42 on: February 15, 2020, 04:18:03 am »

@anewaname: you were right, after painstalkingly checking every mud tile the moss grows under it. So nothing here. The under-lake attempts have been stymied by layer after layer of heavy aquifier obsidian of all things! The caverns below seem unaffected by lake biome. I'm sorry I cannot be of More use in this thread, not having moss is quite a pickle in some scenarios.
Logged

PatrikLundell

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #43 on: February 15, 2020, 07:22:50 am »

@anewaname: you were right, after painstalkingly checking every mud tile the moss grows under it. So nothing here. The under-lake attempts have been stymied by layer after layer of heavy aquifier obsidian of all things! The caverns below seem unaffected by lake biome. I'm sorry I cannot be of More use in this thread, not having moss is quite a pickle in some scenarios.
Obsidian shouldn't be aquifer carrying, so something is wrong there. If obsidian was aquifer carrying in uncorrupted vanilla I believe it would mean that quite a few embarks would have the magma sea essentially replaced by a huge obsidian lump with only a narrow empty space just on top of the SMR tiles (assuming the aquifer changes haven't changed where aquifers appear, only modified the amount of water they produce).
Logged

Ant

  • Bay Watcher
    • View Profile
Re: Moss not growing
« Reply #44 on: February 15, 2020, 10:00:11 am »

@anewaname: you were right, after painstalkingly checking every mud tile the moss grows under it. So nothing here. The under-lake attempts have been stymied by layer after layer of heavy aquifier obsidian of all things! The caverns below seem unaffected by lake biome. I'm sorry I cannot be of More use in this thread, not having moss is quite a pickle in some scenarios.
Obsidian shouldn't be aquifer carrying, so something is wrong there. If obsidian was aquifer carrying in uncorrupted vanilla I believe it would mean that quite a few embarks would have the magma sea essentially replaced by a huge obsidian lump with only a narrow empty space just on top of the SMR tiles (assuming the aquifer changes haven't changed where aquifers appear, only modified the amount of water they produce).

Hmm. I believe I haven't messed with any other raws than adding scales and chitin to be useable as leather (as per wiki). But that stuff under lake is obsidian, 3z levels thick, and definitively aquifier (tried to drill into it at middle level, gave damp stone warning, got through first stones, again damp stone, then whoosh). I need to check that and possibly some other stuff, but as it stands it is beyond scope of this thread.

Edit: attached two pics describing situation

Spoiler: 7zs under lake (click to show/hide)


« Last Edit: February 15, 2020, 12:33:33 pm by Ant »
Logged
Pages: 1 2 [3] 4