Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [40d+] Disappearing saves.  (Read 1159 times)

zwei

  • Bay Watcher
  • [ECHO][MENDING]
    • View Profile
    • Fate of Heroes
[40d+] Disappearing saves.
« on: October 04, 2009, 07:15:07 am »

Description:

I've had this happen two times already in different forts, 40d and 40d16:

Sometimes, saving game does not work, game acts like it saved without error, but next time i tried to load saves game to continue, "region x" contains quite old save (204 year when autosaves are from year 205).

Any idea?

Vince

  • Bay Watcher
    • View Profile
Re: [40d+] Disappearing saves.
« Reply #1 on: October 04, 2009, 08:13:45 am »

Let's copy this:
Quote from: Vince
Make sure you start the correct save, that happened to me, too.
Let's assume you load spring, year 204, play until late summer 206 and save and quit.
The savegame 206-sum will be the autosave from early 206, while the savegame you loaded in the beginning, 204-spr holds your manually saved game from late summer 206.
This is because you are supposed to only load the embark-savegame and save on this. The seasonal saves are just backups.
There you go :)
Logged

zwei

  • Bay Watcher
  • [ECHO][MENDING]
    • View Profile
    • Fate of Heroes
Re: [40d+] Disappearing saves.
« Reply #2 on: October 04, 2009, 08:57:25 am »

There you go :)

Thank you a ton. Yay, my fortress is back! Yay, it was not eaten by bug!

Particleman

  • Bay Watcher
    • View Profile
Re: [40d+] Disappearing saves.
« Reply #3 on: October 07, 2009, 02:31:27 am »

This happened to me when I first started too. For some reason nobody thought it was worth mentioning that when you load a game, it saves to the same folder you loaded from, not the folder created by the autosave (if you play long enough for it to autosave).
Logged

zwei

  • Bay Watcher
  • [ECHO][MENDING]
    • View Profile
    • Fate of Heroes
Re: [40d+] Disappearing saves.
« Reply #4 on: October 09, 2009, 06:20:29 am »

Guess this is common enough problem, i added little notice to wiki: http://www.dwarffortresswiki.net/index.php/Saved_game_folder

It should be googlable now :)