Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Poll

This version of LNP is out of date

Yes and it makes me sad :(
- 57 (39.6%)
Yes and it makes me mad/angry/frusrated >:(
- 22 (15.3%)
Yes and it's okay because there are other versions now :)
- 65 (45.1%)

Total Members Voted: 144


Pages: 1 ... 38 39 [40] 41 42 ... 137

Author Topic: Lazy Newb Pack - Very out of date :(  (Read 1472584 times)

NW_Kohaku

  • Bay Watcher
  • [ETHIC:SCIENCE_FOR_FUN: ACCEPTABLE]
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #585 on: February 08, 2011, 09:22:58 pm »

I have to say, I'm someone who doesn't really use all the graphics packs or whatnot, but generally speaking, I have a lot of custom init options I like. 

For one, I can't play without using 5 and 0 as "up (z-axis)" and "down (z-axis)", respectively.  The idea that the numpad is used for directional control in every direction but vertical, and those keys require repositioning your hand across the keyboard is just absurd in my mind. 

I also have a personal custom tileset, a personal preference on things like the brightness of the colors, and a few other odd things that take messing with raws or init options to put in. Because I have to spend so much time messing with these things, I generally find it easier to put up with bugs than update my game version except every 4 versions or so. 

I find the graphical interface you guys put on this to be very useful and intuitive and I commend you on it. 

I would ask something, however, to maybe make it more useful to still lazy, but less newb players:  Make some sort of way to import settings from a previous version of the game into the new version of the game, without having to just copy-paste the init files over, that the init files warn us not to do by just copy-pasting. 
Logged
Personally, I like [DF] because after climbing the damned learning cliff, I'm too elitist to consider not liking it.
The Economy isn't like a big truck.  It's more like a series of rubes.

Improved Farming
Class Warfare

TolyK

  • Bay Watcher
  • Nowan Ilfideme
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #586 on: February 08, 2011, 11:04:05 pm »

I would ask something, however, to maybe make it more useful to still lazy, but less newb players:  Make some sort of way to import settings from a previous version of the game into the new version of the game, without having to just copy-paste the init files over, that the init files warn us not to do by just copy-pasting.
hm.... that could take some time when the raws change...
Logged
This isn't what you think, this is just a sentence in my signature.

LucasUP

  • Bay Watcher
  • Devout Cheeseist
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #587 on: February 08, 2011, 11:28:52 pm »

I made a Lazy Newb package with Bentgirder region file already installed.  :D Let me know if there's any problems with it.

http://dffd.wimbli.com/file.php?id=3636
Hey cool! (Links/DFFD is down atm though)
But is the savegame still from 31.16 or whatever? Or did you re-embark and generate?
Because there are severe gameplay bugs and glitches going from 31.16 to 31.18

@NW_Kohaku yeah that may be too difficult to do, because we can't anticipate updates in the init file and such. It could be done, so it only updates the tags it finds similar in new versions. It'd probably be a decent amount of work though so wouldn't promise on that.
« Last Edit: February 08, 2011, 11:30:29 pm by LucasUP »
Logged
Lazy Newb Pack [0.34.11] [V15] GUI + Dwarf Fortress + Graphics + Dwarf Therapist & More!

Thundercraft

  • Bay Watcher
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #588 on: February 09, 2011, 12:40:56 am »

Question:

Why does the latest release install both Quickfort v2.00pre3 and Quickfort v1.11 ? Why include the old version at all? Isn't that a bit redundant and a waste of disk space / download size?
Logged

LucasUP

  • Bay Watcher
  • Devout Cheeseist
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #589 on: February 09, 2011, 03:13:38 pm »

-Mostly because I initially thought 2.00pre3 was a beta and that I would remove 1.11 once the final came out.
-Quickfor v1.11 is a whole 335 KB :P
-Also because the file format is different for both of them, so if anyone had spreadsheets for 1.11 they would still be able to use them.

Since the final hasn't come out in so long, and if there are no significant problems with 2.00, I may remove 1.11 just so things are cleaner, but is that really a good enough reason to remove it?
Logged
Lazy Newb Pack [0.34.11] [V15] GUI + Dwarf Fortress + Graphics + Dwarf Therapist & More!

NW_Kohaku

  • Bay Watcher
  • [ETHIC:SCIENCE_FOR_FUN: ACCEPTABLE]
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #590 on: February 09, 2011, 06:13:22 pm »

@NW_Kohaku yeah that may be too difficult to do, because we can't anticipate updates in the init file and such. It could be done, so it only updates the tags it finds similar in new versions. It'd probably be a decent amount of work though so wouldn't promise on that.

I don't mean to "anticipate changes", I mean to help people adapt to changes that are already here.  I mean make a function to import the init settings of my 31.03 or 31.08 versions up to 31.18.  In other words, make a lazy newb pack that helps players update their old fortress and init settings to the current version in a fast and easy way, rather than exports what you make in this version to the future versions.
Logged
Personally, I like [DF] because after climbing the damned learning cliff, I'm too elitist to consider not liking it.
The Economy isn't like a big truck.  It's more like a series of rubes.

Improved Farming
Class Warfare

Johnfalcon99977

  • Bay Watcher
  • The Herp Derp Assassin
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #591 on: February 09, 2011, 08:43:26 pm »

I've noticed theres the ability to enable the economy. What happens if I switch this to on?
Logged
Also known as the Knowlagable, the Forgetful, and/or the Ignored

Please excuse my horrible awful linguistic skills.

Thundercraft

  • Bay Watcher
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #592 on: February 09, 2011, 08:51:30 pm »

I've noticed theres the ability to enable the economy. What happens if I switch this to on?
When in doubt, wiki it:
Quote
In the current version, there are no conditions under which the economy will activate. Toady One has stated that it may come back in after sweeping changes are made to make it less broken.

Even if there was some way to turn the economy on and get it to work like in previous versions, you'd probably just be flushing your Frames Per Second down the toilet.
Logged

Strangething

  • Bay Watcher
  • Slizardman
    • View Profile
    • My Livejournal
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #593 on: February 10, 2011, 12:32:09 am »

I made a Lazy Newb package with Bentgirder region file already installed.  :D Let me know if there's any problems with it.

http://dffd.wimbli.com/file.php?id=3636
Hey cool! (Links/DFFD is down atm though)
But is the savegame still from 31.16 or whatever? Or did you re-embark and generate?
Because there are severe gameplay bugs and glitches going from 31.16 to 31.18

Yeah, it's the same old save. How bad are those bugs?

I should generate a new world and a new embark location every few versions. Then I'd need to update the tutorial to be location-agnostic. Right now it mentions the location of metal deposits and such. I could give my starting seven nicknames that would stay the same from version to version.

If only I had the time.
Logged
I'm looking for a volunteer to take over the Bentgirder project. Let me know if you're interested.
I'm a TF2 newbie. Want to trade?

Thundercraft

  • Bay Watcher
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #594 on: February 10, 2011, 12:59:58 pm »

The warning on the front page states: "If you have a savegame that is from v0.31.16 or earlier,
do NOT update it to v0.31.18 or newer, doing so will break your save!" 

I took this to mean that I couldn't bring my 31.16 saves into 31.18.  Am I wrong?
Thanks for getting the new version out!  As a lazy newb I really appreciate it.

Could you go into some detail on why you can't update DF 31.16 saves?  Are there any work arounds?  Or point me in the direction of what's causing the problem to see if I can manually get around it? 

My current fort is in 31.16 and I'd really like to move it up to 31.18.

I don't know the details. I'm copying the warning over from Phoebus' thread. I assume save compatibility has been broken, meaning no, you really shouldn't move your save files over.
Edit: Actually it probably means you CAN copy your saves over, but only if you NEVER RUN THE SAVE-GAME UPDATER or it will break the saves! (also meaning you can't change/update graphics for it)

Isn't updating the raws in your Bentgirder save the same thing as running a save-game updater?

From what I recall reading in the Phoebus graphics thread, trying to update the raws results in several pages of "Unit has misaligned bp modifiers.  Adjusting." in the DF errorlog. Also, the original Bentgirder save was for an ASCII version of DF, correct? I think trying to update the raws for Lazy Newb pack with Phoebus (and several other) graphics may result in really weird graphics glitches.
« Last Edit: February 10, 2011, 01:06:56 pm by Thundercraft »
Logged

TolyK

  • Bay Watcher
  • Nowan Ilfideme
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #595 on: February 10, 2011, 01:05:09 pm »

it's strange. some worlds of mine work, some don't.
Logged
This isn't what you think, this is just a sentence in my signature.

Strangething

  • Bay Watcher
  • Slizardman
    • View Profile
    • My Livejournal
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #596 on: February 10, 2011, 01:53:04 pm »

Isn't updating the raws in your Bentgirder save the same thing as running a save-game updater?

From what I recall reading in the Phoebus graphics thread, trying to update the raws results in several pages of "Unit has misaligned bp modifiers.  Adjusting." in the DF errorlog. Also, the original Bentgirder save was for an ASCII version of DF, correct? I think trying to update the raws for Lazy Newb pack with Phoebus (and several other) graphics may result in really weird graphics glitches.

Huh. I've used the updated save with several graphics packs without any problems. Perhaps this is something specific to Phoebus?

Checking my errorlog, it looks like I do have those "misaligned bp modifier" errors. I have not seen any graphical glitches, though.
Logged
I'm looking for a volunteer to take over the Bentgirder project. Let me know if you're interested.
I'm a TF2 newbie. Want to trade?

Hyndis

  • Bay Watcher
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #597 on: February 10, 2011, 10:14:43 pm »

I'm sorry, I'm probably being a complete newb and missing something blindingly obvious...


So I downloaded the 31.18 version of this (much <3!!) and set up the Mayday graphics set, which is my favorite. That all works fine.

However the game menus use a completely different kind of font. It doesn't use the Mayday graphics set characters. Is there any way to get the game menus to also use the Mayday graphics set? Mostly because the in game menu is used for things such as the stocks menu or looking at items. It seems to be broken in that it doesn't properly display the item quality for very high level quality items, like masterworks, so its hard to differentiate masterworks from other items at a glance.

31.16 didn't have this issue, so everything was using the same character set, both in game and on the menus including on the in game menu on the right side of the screen for the various commands and whatnot.
Logged

LucasUP

  • Bay Watcher
  • Devout Cheeseist
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #598 on: February 11, 2011, 01:03:22 am »

Nope not a Newb question.
The problem you're having I think is that tilesets are starting to use the TTF (true type font) support, which is kinda wonky at the moment.

You can switch back to the old ways by changing "[TRUETYPE:YES]" to "[TRUETYPE:NO]" inside init.txt. The easiest way to do this:
Click "Init File Editor" button, scroll down the LEFT box, find [TRUETYPE:YES], change it, and SAVE.
Logged
Lazy Newb Pack [0.34.11] [V15] GUI + Dwarf Fortress + Graphics + Dwarf Therapist & More!

Hyndis

  • Bay Watcher
    • View Profile
Re: Lazy Newb Pack [0.31.18] [V7.0] With Graphical User Interface!
« Reply #599 on: February 11, 2011, 01:24:30 am »

Nope not a Newb question.
The problem you're having I think is that tilesets are starting to use the TTF (true type font) support, which is kinda wonky at the moment.

You can switch back to the old ways by changing "[TRUETYPE:YES]" to "[TRUETYPE:NO]" inside init.txt. The easiest way to do this:
Click "Init File Editor" button, scroll down the LEFT box, find [TRUETYPE:YES], change it, and SAVE.

Ohsnap. It worked!

Yay, thank you!  :D
Logged
Pages: 1 ... 38 39 [40] 41 42 ... 137