Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Catastrophic modding error  (Read 1021 times)

Gizogin

  • Bay Watcher
  • [EVIL][RAWMANCER]
    • View Profile
Catastrophic modding error
« on: November 07, 2011, 09:16:09 am »

A while ago, as some of you may remember, I embarked on a modding quest to create a completely indestructible creature.  The end result of my labors was the fluffball, a living ball of fluff with no organs, blood, appendages, or functional tissue.  These features made it nearly impossible to kill.  Oddly, however, during my last fortress, I began to find fluffball corpses scattered around the halls.  I dismissed this as a fluke and went on. 

Later, after this fortress fell to a combination of many factors, I embarked on a sinister biome.  There I saw something very odd: a swarm of zombie fluffballs.  Their description contained the line "His/her body is gone."  Intrigued, I went to the arena.  There, I made a zombie fluffball and a dwarf.  I took control of the dwarf, and when I tried to use an aimed attack on the fluffball, nothing happened.  I don't mean that I missed, I mean that there was no body part to aim my attack at.  I then tried a normal, unaimed attack, at which point DF promptly crashed.  Because my fluffballs have no structural body parts, there was nothing for the zombie coding to leave behind. 

Clearly, I have accidentally made something that is so invulnerable that just trying to harm it divides by zero and ends the universe.

If anyone wants to confirm my results, the raw file for the fluffball is here:
Spoiler (click to show/hide)

Also, feel free to share any similar experiences you have had with oversights in modding.
Logged
Quote from: franti
"Let's expose our military to zombie-dust so they can't feel pain. They don't NEED skin."
Quote from: Ipwnurmom221
One FB post. Many dick jokes. Pokemon. !!VOLCANO!!. Dwarven mood thingee. Derailment itself. Girlinhat's hat. Cuba. Karl Marx. This is why i love Bay12 forums.
The rest of my sig.
Fear the fluffballs

Trapezohedron

  • Bay Watcher
  • No longer exists here.
    • View Profile
Re: Catastrophic modding error
« Reply #1 on: November 07, 2011, 09:44:24 am »

You just created an entity of nothing! Quickly encase it in a magma/water solution!

On topic, I made forgotten beasts occupy various civilizations because of an oversight in the entity raws. Needless to say, it was a funky adventure, since one-eyed humanoid lizards with deadly dust attacks occupied a civilization and practically curb-stomped their enemies in wars, provided the enemy wasn't a forgotten beast too.
Logged
Thank you for all the fish. It was a good run.

Putnam

  • Bay Watcher
  • DAT WIZARD
    • View Profile
Re: Catastrophic modding error
« Reply #2 on: November 07, 2011, 09:46:13 am »

Yeah, but duped raws (as described in above post) are pretty normal things.

IamanElfCollaborator

  • Bay Watcher
  • Resident God of Shipping (and Posting)
    • View Profile
    • The Final Fantasy Mod. Welcome to the world of Bahamut!
Re: Catastrophic modding error
« Reply #3 on: November 07, 2011, 10:37:32 am »

I can see how the fluffballs of nothingness would cause doom for your fort. Try adding an extra bodypart, or else add [CANNOT_UNDEAD] to them.

EDIT:I see that's been solved. Disregard my post unless it is relevant.
« Last Edit: November 07, 2011, 11:09:03 am by IamanElfCollaborator »
Logged