Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Upgraded graphics card, DF stopped working.  (Read 2874 times)

Tharg

  • Bay Watcher
    • View Profile
Upgraded graphics card, DF stopped working.
« on: September 05, 2007, 05:16:00 pm »

DF has worked fine with my Radeon 9250 (got about 35 fps with temp and weather on and 150 dwarfs) and my onboard G965 type graphics (got about 20 fps in the same fort).

I have recently invested in a Radeon x1950 Pro (damn Bioshock), and the game no longer starts.  I should probably mention that I have the latest drivers for the card and have also installed the Bioshock hotfix.  DF prompts me for Full Screen or Windowed, then if I select Windows the resolution changes.  Then either way  get "dwarfort.exe has encountered a problem and needs to close.  We are sorry for the inconvenience.  etc ...".

I've tried rebooting, re-downloading and re-installing, and fidding aimlessly with the Catalyst Control Center settings, but no luck so far.

I can post the "technical information" from the error if it's helpful.

Any ideas very welcome.

Logged

Lord Nightmare

  • Bay Watcher
    • View Profile
Re: Upgraded graphics card, DF stopped working.
« Reply #1 on: September 05, 2007, 09:18:00 pm »

Almost certainly an openGL problem. Be SURE openGL is enabled and working.

LN

Logged
"When life gives you zombies... *CHA-CHIK!* ...you make zombie-ade!"

Tharg

  • Bay Watcher
    • View Profile
Re: Upgraded graphics card, DF stopped working.
« Reply #2 on: September 06, 2007, 01:54:00 pm »

Yeah, you seem to be right, opengl is not working.  Everything about it is fine in the various system information places, but opengl apps just refuse to start.

I've even updated my Chipset drivers.  And I have the latest BIOS version.

Dammit it's a hassle to take it out every time I want to play df.

Logged

Tharg

  • Bay Watcher
    • View Profile
Re: Upgraded graphics card, DF stopped working.
« Reply #3 on: September 10, 2007, 06:16:00 am »

Just to follow up - I figured out a work around for my problem by using the GLDirect wrapper, long with a free code, from here.  I expect it'd be a good workaround for anyone with OpenGL problems with the game.
Logged