Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Bug?  (Read 550 times)

ninja137

  • Bay Watcher
    • View Profile
Bug?
« on: October 23, 2010, 10:13:57 pm »

Hi, I seem to be having a bit of trouble generating a world. Until now the settings I had worked fine, never got an error. I just tweaked the amount on volcanoes in an attempt to get a volcano in an area that would be good for me. After I did that, I got an error that says the world gen is having problems placing enough low elevations. Could this be the volcanoe settings? Or is that a bug? Is there any way that I can get more volcanoes/access to lava aside from a gigantic fps killing pumpstack?
Logged

ninja137

  • Bay Watcher
    • View Profile
Re: Bug?
« Reply #1 on: October 23, 2010, 10:18:15 pm »

It turns out I am getting many other errors. Such as rainfall, not able to place high elevations, and volcanism.

Edit: I have errors for TONS of things now. Was this all from the volcanoes?
« Last Edit: October 23, 2010, 10:20:47 pm by ninja137 »
Logged

Johnny Madhouse

  • Bay Watcher
    • View Profile
Re: Bug?
« Reply #2 on: October 23, 2010, 10:25:18 pm »

Something that makes genning worlds a lot easier is to find the RANGES tags and set all of the numbers in them to zero. REGION_COUNTS tags also can be set to zero for far fewer rejections.

ELEVATION_RANGES, RAIN_RANGES, DRAINAGE_RANGES, SAVAGERY_RANGES, VOLCANISM_RANGES will all be at the very end of each entry. Set all three numbers following them to zero as well, and you should be fine.
Logged
Useless migrants go the Culling Burrow.