Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 38 39 [40]

Author Topic: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support  (Read 188986 times)

Boltgun

  • Bay Watcher
  • [UTTERANCES]
    • View Profile
    • Github
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #585 on: September 16, 2020, 02:14:50 pm »

I think that's was the magma well's output that someone made its way into your adventurer's vicinity. That should not be hard to fix but maybe at the cost of the wells turning off if you retire a fort.
Logged
Succubus civ : Vanilla - Masterwork
Let's plays: Youtube - Piratez - Twitch

Artwr

  • Bay Watcher
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #586 on: September 20, 2020, 12:27:32 am »

I got a High Treasurer and a liaison this summer, in a brand new world (want to test adventurer mode without using magma wells). Both opened up the window for trade agreement, asking what I wanted and so on. Went on the civ page, got four trade agreements, two for import, two for exports.
Is this intended, or something with the "using fortresses for a while" thing?
Logged

GarlicBread

  • Bay Watcher
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #587 on: September 21, 2020, 01:45:54 am »

I kinda missed the heat up the forges because I ended up using it a lot :p
Logged
He still hasn't killed any of the horses. Instead he went out, beat a cougar to death with his bare hands, and dragged it back to the butcher's shop. I was not expecting that.
Starvation is staved off for another day, anyways.

reeverdark

  • Escaped Lunatic
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #588 on: October 07, 2020, 03:33:29 pm »

Hi ya!

I'm having some technical difficulties. I don't know if this is user error, in terms of installation, a bug or what, however;

My game is crashing with this mod. With the starter pack stuff installed, the game lasts a few minutes before it dies spontaneously. Without the starter pack stuff, and just fresh with the mod win version, it crashes at embark (basically after you prepare, and press E to go, then any key after that to go to your location(the one with the long ass message about arriving), it will crash on key press).   

Things i've tried:

>>Taking the winversion, putting it into a seperate folder, then 1 folder up placing the LNP stuff there, adjusting some settings to what i favour and launching the game --- Results in crash after 1 to 2 min.
>>Patching a fresh version (the newest) of LNP with the mods patch version --- Crashes after a min or 2.
>>Loading the winversion without LNP etc --- crashes on embark as stated before.

I have tired a few different setting in LNP as well as things like the performance improvements etc, both off and on but the results are the same.

My PC specs are as follows:
=========================
Operating System
   Windows 10 Pro 64-bit -- [Most recent version]
CPU
   Intel Core i7 7700 @ 3.60GHz   
   Kaby Lake 14nm Technology
RAM
   32.0GB
Motherboard
   ASRock Z390 Phantom Gaming-ITX/ac (CPUSocket)   
Graphics
   BenQ GW2265 (1920x1080@60Hz)
   BenQ GW2265 (1920x1080@60Hz)
   HUION (1920x1080@60Hz)
   4095MB NVIDIA GeForce RTX 2080 SUPER (MSI)   
Storage
   953GB ADATA SX8200PNP (Unknown (SSD))
   476GB Samsung SSD 860 PRO 512GB (SATA (SSD))
Audio
   TC-Helicon GoXLR Mini
=========================

Naturally i get that, with this little of information its unlikely that a reason for this can be found as is, but if you can think of anything i can check or info you may need that i might be missing, please feel free to ask.

I really love this mod, and have played it intensively all the way back when i was playing with it on Masterwork (it would still crash but back then as well, but i could be playing for hours and it would be fine, so pretty much standard DF behaviour), and i would really love to try it with the newest version of DF. If i can get this to work, i have plans on a massive tower build, make from obsidian. I plan for it to be the (in games)worlds largest library ever created, with Succubi being the custodians of wisdom and lust!

Anyhow, idk if this issue is a conflict with my hardware, or some erroneous bug somewhere with something. Just to note, other than what comes with LNP, no other mods have been used with this one.


Edit: Ok, tested marterwork and i have the same issue (this is a new PC compared to the one i used masterwork on 2 years ago). This is most likely not the mods fault, but something with my PC and DF in general? Odd though since vanilla runs fine.


Edit, of the edit + a lot of apologising... : So after a day or 2 since i posted this, i did some extra digging, and it seems that the issue is high likely to be this>> http://www.bay12games.com/dwarves/mantisbt/view.php?id=11549 << truth be told i didnt know this bug tracking site existed untill i spent half my day desperatly trying to find out if this issue was in fact a seperate this or i'd gone messed up somewhere,,,

If what i read is correct, and what im getting is basically this, then its also highly likely that its DF completely and nothing to do with this mod... if so, i apologize, since this fact could very well render this entire post reply irrelevant... Oh well... if you do however know a work around regardless, im all ears :D here's to looking forward to more developments of the great mod!

« Last Edit: October 08, 2020, 09:20:29 pm by reeverdark »
Logged

Artwr

  • Bay Watcher
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #589 on: September 04, 2021, 05:14:20 pm »

I get anxious everytime I open this thread and see nothing new, I really like this mod. Is Boltgun awaiting the steam release, or got busy with other things in life?
Logged

Artwr

  • Bay Watcher
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #590 on: December 30, 2021, 10:57:55 pm »

I got a world with Ogres available at embarks, for 1 point each.
Since I use LNP, the labormanager allowed me to give them labors. They could be put into squads, but not as leaders.
They were also slow as hell.
Anyone else got one of those? I think It may have something to do with the civ being dead (got a demon prince right at the start).
Logged

goldenvixen

  • Bay Watcher
  • Pilum Murialis
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #591 on: February 17, 2022, 02:26:27 am »

Hey, sorry for the late response in my error, life got carried away for me there for a while. I haven't been able to replicate my trader caravan crash, but I got a new bug. Not game breaking as the last, but slightly annoying. A lot of my succubi don't have names for some reason. And my fortress doesn't have a name either. It's making finding certain workers confusing, but can be worked around by giving them nicknames. Sadly, the names I can only think of are immersion breaking. Looking in my error log, I got this:

Code: [Select]
*** Error(s) finalizing the translation SUCCUBUS
Unrecognized word token: BEER
Unrecognized word token: BOAR
Unrecognized word token: BUCK
Unrecognized word token: CAD
Unrecognized word token: DEVOURER
Unrecognized word token: DRUM
Unrecognized word token: FLUTE
Unrecognized word token: HOP_NOUN
Unrecognized word token: KING
Unrecognized word token: LUTE
Unrecognized word token: OX
Unrecognized word token: QUEEN
Unrecognized word token: RAM
Unrecognized word token: SNAKE
Unrecognized word token: WHISKY
Unrecognized word token: WITCH
Unrecognized word token: BUNNY
Unrecognized word token: CHURCH
Unrecognized word token: TRUMPET
Unrecognized word token: MONASTERY
Unrecognized word token: CONVENT
Unrecognized word token: CATHEDRAL
Unrecognized word token: CHAPEL
Unrecognized word token: UMBER
Unrecognized word token: COMPANY

I'm not quite sure what's going on here. I looked in the succubus language file, and I'm not seeing any characters that would be unfriendly with linux computers since that was my first thought. I'll post my save in case you need to take a look at it.

//edit: now it's just crashing after five years in. I'm not sure exactly what's going on, but here's an updated save file. https://www.dropbox.com/s/u53owmswjnri2xj/region1.rar?dl=0
//editedit: Comparing languages, it just looks like the language needs an update since more has been added to languages. I'm gonna have them speak dwarfish for now until that's fixed to see if that helps with the no names in a new game.
//editedit: another weird thing--I can't seem to get the succubi to wear layered glass gauntlets. But, I can get them to wear other layered glass armor oddly enough.
« Last Edit: February 19, 2022, 07:13:22 pm by goldenvixen »
Logged

cerevox

  • Bay Watcher
    • View Profile
Re: [47.04] Succubus Dungeon 17.0 - Now with multi lovers support
« Reply #592 on: March 03, 2022, 08:30:44 pm »

So my understanding is that you can put frog demons into the military, but I don't seem to be able to. I can't assign them to squads with therapist or from the in-game unit menu or the military menu. Is there some other requirement I am missing?

Edit: Okay, after some more fooling around, it turns out that you can conscript frogdemons you summon, but not ones that come with migrants. Still not sure one the ones born at the fort, all too young still.
« Last Edit: March 04, 2022, 12:06:28 am by cerevox »
Logged
Pages: 1 ... 38 39 [40]