Bay 12 Games Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: [40d and older]Mysterious Repeatable Crash  (Read 3838 times)

Keldor

  • Bay Watcher
  • Blood for the blood god!
    • View Profile
[40d and older]Mysterious Repeatable Crash
« on: August 26, 2008, 12:25:58 am »

I have a particular save that keeps crashing a few days into the month of Malachite.  If I had to guess what was causing it, I'd guess that the human caravan was trying to arrive while the humans were already siegeing the fortress.  I'll get a link up to the save file shortly.

This problem has persisted through multiple versions, though I only now got around to confirming it as a repeating crash, and not just random crashs.

Here's the save:
http://dffd.wimbli.com/file.php?id=479
« Last Edit: September 07, 2008, 12:59:36 am by Keldor »
Logged
If ignorance is bliss, why are my dwarves all tantruming?

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: [40c and older]Mysterious Repeatable Crash
« Reply #1 on: September 02, 2008, 06:12:34 pm »

There was a typo in the siegers' campfire code.  When the fires went out, so did the game.  Fixed for next time.  They were on horsies.  I'm glad that part's working, though wrestlers on horseback seems sort of weird to me.  There are about a dozen groundhogs and groundhog pups in a dried out pool.
Logged
The Toad, a Natural Resource:  Preserve yours today!

Keldor

  • Bay Watcher
  • Blood for the blood god!
    • View Profile
Re: [40c and older]Mysterious Repeatable Crash
« Reply #2 on: September 03, 2008, 04:10:59 am »

A couple other semi-related things:

First, the human siegers flee from my dwarves, although they will use bows if they have them.  Looks like they're using the civilian AI that hunters use concerning battle.

Second, cage traps catch the mount, but not the rider.  Seems like they should catch both.

You gotta love that groundhog swimming pool, though XD  I imagine that the mommy pathed into the pool when it was half full, and then it dried up.  Why they didn't try to path out of it when the pool began filling up again (though it never made it all the way before the dry season hit again) is a good question.
Logged
If ignorance is bliss, why are my dwarves all tantruming?

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: [40c and older]Mysterious Repeatable Crash
« Reply #3 on: September 06, 2008, 06:17:34 pm »

It's probably the horses that are running away, using some kind of wilderness animal code.  The humans are just along for the ride, though I'm not sure, since they seem to manage the fires all right.  I'll have to check.  Do humans without mounts run away?
Logged
The Toad, a Natural Resource:  Preserve yours today!

Keldor

  • Bay Watcher
  • Blood for the blood god!
    • View Profile
Re: [40d and older]Mysterious Repeatable Crash
« Reply #4 on: September 07, 2008, 12:58:36 am »

Updated to 40d, but the crash still happens, although about a week later than before.
Logged
If ignorance is bliss, why are my dwarves all tantruming?

numerobis

  • Bay Watcher
    • View Profile
Re: [40c and older]Mysterious Repeatable Crash
« Reply #5 on: September 07, 2008, 12:43:50 pm »

It's probably the horses that are running away, using some kind of wilderness animal code.  The humans are just along for the ride, though I'm not sure, since they seem to manage the fires all right.  I'll have to check.  Do humans without mounts run away?

I just had a human siege (my first! it's apparently worth going to war with me for not defending their lone diplomat against 50 goblins) and noticed the mounted human wrestler ran, but the soldiers on foot fought until about half had died.
Logged

Toady One

  • The Great
    • View Profile
    • http://www.bay12games.com
Re: [40d and older]Mysterious Repeatable Crash
« Reply #6 on: September 07, 2008, 02:32:17 pm »

This time the crash seems to be related to the screw pump on the right side of the fortress one level below the surface.  I haven't figured out why yet, but it's crashing during the regular old water pumping routine.  I've disconnected the axle in that wooden siltstone tunnel, and I'm currently running it to see if that prevents the crash.  Of course, I have no idea if that pump is crucial in some sort of dwarf survival/productivity kind of way.  Perhaps I'll figure out before I reach the 10th of Malachite.

Update:  I got pretty far along (14th), and it seems fine.  Still not sure on the root cause.  I guess the pump runs that waterfall pillar circuit.  Perhaps when enough water evaporates something is becoming unstable.  Probably just have to find a typo somewhere.
« Last Edit: September 07, 2008, 02:49:55 pm by Toady One »
Logged
The Toad, a Natural Resource:  Preserve yours today!